[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

bug in bessel function in glibc 2.1

I don't know if you folks know about this bug yet.  I don't want
to file the 20th report.  I will file a bug report if 
someone says it has not been done.
This report is for RH 6.0, I tried it on potato and the bug occurs
there as well. I tried it under Digital UNIX and the bug did not
occur.  Someone (I think the RH people) have identified the
bug, it is a single incorrect index (I don't have the reference).

The following report is from the perldl mailing list. Please
CC me if you need more informatin from me.

i replied to karl, but it looks like it didn't make it to the list
(shoulda checked the headers before sending....).  anyway, the problem
with bessyn under RH 6.0 stems from the yn function in libm being
fscked somehow.  compiling and running this C code:

#include <stdio.h>
#include <math.h>

int main(void) {

  double x;

  x = yn(2,0.2);

  printf("%12.9f\n", x);

  return 0;


under RH 6.0 gives -32.223870297 whereas under solaris 2.6 it
gives -32.157144559.  i haven't tested other linux dists, but will
tonight. i'll also post a bug report to bugzilla.redhat.com.

John Lapeyre <lapeyre@physics.arizona.edu>,  lapeyre@debian.org
Tucson,AZ     http://www.physics.arizona.edu/~lapeyre

Reply to: