[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#35378: marked as done (libc6: ttyname(_r) result not properly terminated [fix included])

Your message dated Tue, 11 May 1999 01:05:22 -0700
with message-id <v04204e05b35d94ca397b@[]>
and subject line Forgot to close these
has caused the attached bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I'm
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Ian Jackson
(administrator, Debian bugs database)

Received: (at submit) by bugs.debian.org; 31 Mar 1999 22:16:58 +0000
Received: (qmail 29102 invoked from network); 31 Mar 1999 22:16:57 -0000
Received: from atari.ne.mediaone.net (HELO janitor.wilmcd.com) (qmailr@
  by master.debian.org with SMTP; 31 Mar 1999 22:16:57 -0000
Received: (qmail 3005 invoked from network); 31 Mar 1999 22:16:56 -0000
Received: from localhost (HELO wilmcd.com) (root@
  by localhost with SMTP; 31 Mar 1999 22:16:56 -0000
Message-ID: <37029ED7.4F5BA51F@wilmcd.com>
Date: Wed, 31 Mar 1999 17:16:55 -0500
From: "William R. McDonough" <wrmcd@wilmcd.com>
Reply-To: wrmcd@wilmcd.com
X-Mailer: Mozilla 4.51 [en] (Win95; U)
X-Accept-Language: en
MIME-Version: 1.0
To: submit@bugs.debian.org
Subject: libc6:  2.2.5ac1 & screen
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

Package:  libc6
Version:  2.1.1-0.1

from linux-kernel
If some of you watch the linux-kernel list you saw my question today.
Here is Alan Cox's reply.

I hope this helps to fix everything.


Delivered-To: wrmcd@wilmcd.com
From: alan@lxorguk.ukuu.org.uk (Alan Cox)
Subject: Re: 2.2.5ac1 & screen
To: wrmcd@wilmcd.com
Date: Wed, 31 Mar 1999 23:29:18 +0100 (BST)

> I tried downgrading the kernel, and screen...  Is there any work

Its not a kernel bug that Im sure of. I think its a Debian glibc bug. It

only affects debian potato. We know of one glibc bug that it might
and that is a bug in glibc 2.1 ttyname(). If it works with /proc
you need to get the debian folks to fix their glibc


To: linux-kernel@vger.rutgers.edu
Subject: 2.2.5ac1 & screen
Sender: owner-linux-kernel@vger.rutgers.edu
X-Loop: majordomo@vger.rutgers.edu
X-Orcpt: rfc822;linux-kernel-outgoing-dig

I noticed Alan wrote in his release notes this breaks screen.
It broke mine.

I tried downgrading the kernel, and screen...  Is there any work around?

Here is what I am seeing...

I'm running Debian 2.2 (potato)

[wrmcd@janitor: ~]$ screen -S bitchx bitchx
Cannot access '/dev/ttypÿÿÿÿÿÿÿÿ': No such file or directory

Reply to: