[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#36775: incompatible mktime() behavior under Debian Linux 2.2.1 (formerly used 2.033)

On Tue, 27 Apr 1999 09:45:25 -0600 (MDT), Gerry Wiener wrote:
>Package: libc6
>The version of mktime() in Debian 2.2.1 has incompatible behavior
>from that of Debian 2.0.33.  Note that 2.2.1 uses  /lib/libc-2.0.7.so.

I don't recognize these version numbers.  They look like kernel versions,
but the kernel has nothing to do with the implementation of time zones.  Are
you possibly comparing Debian 1.3 (which shipped kernel 2.0.33 IIRC) with
Debian 2.0?  If so, the relevant difference is that 1.3 came with a
completely different C library: libc5, rev 5.4.23 IIRC.  libc6 does not
implement a lot of obsolete stuff relating to time zones and I think the
feature you're trying to use is one of them.


Reply to: