[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade orfeotoolbox to 5.0

On Mon, Aug 10, 2015 at 5:28 PM, Rashad M <mohammedrashadkm@gmail.com> wrote:

On Mon, Aug 10, 2015 at 4:18 PM, Johan Van de Wauw <johan.vandewauw@gmail.com> wrote:
On Mon, Aug 10, 2015 at 4:03 PM, Rashad M <mohammedrashadkm@gmail.com> wrote:
> Hi,
> I am having a problem to update upstream
> when running uscan --download --verbose
>  Scanning for watchfiles in .
> -- Found watchfile in ./debian
> -- In debian/watch, processing watchfile line:
> http://sf.net/orfeo-toolbox/OTB-(\d[\d\.]+)\.(?:tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz)))
> uscan warning: In watchfile debian/watch, reading webpage
>   https://qa.debian.org/watch/sf.php/orfeo-toolbox/ failed: 500 Can't
> connect to qa.debian.org:443
> -- Scan finished
> I am behind a proxy and I checked that http_proxy and https_proxy env vars
> are set properly. But still didn't work.

Hello Rashad,

I get the same error if I don't properly set my proxy variables. What
works for me is:

http_proxy=http://proxy.xxx.be:8080 uscan --verbose --download

I had the proxy setting earlier but didnt work. I had tested the same command on my colleague  and uscan works!

Google pointed out a debian bug report


I had tried the GET command mentioned in one of the comments. Here is the output.

/usr/bin/GET https://qa.debian.org/watch/sf.php/orfeo-toolbox/

SSL connect attempt failed error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol at /usr/share/perl5/LWP/Protocol/http.pm line 47.

BTW, uname -a gives
Linux debian-sid 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt4-1 (2015-01-16) x86_64 GNU/Linux

The workaround mentioned in [1] is working for me. So i will put it here in case if anyone runs into the same.

set http_proxy , https_proxy and others

after that change

https_proxy=https://<proxy host:port>


https_proxy=http://<proxy host:port>

and now uscan works as normal

[1] https://rt.cpan.org/Public/Bug/Display.html?id=1894#txn-75715

Kind Regards,



Reply to: