[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gnat-4.6_4.6.3-3_armhf.changes ACCEPTED into unstable





Accepted:
gnat-4.6-base_4.6.3-3_armhf.deb
  to main/g/gnat-4.6/gnat-4.6-base_4.6.3-3_armhf.deb
gnat-4.6_4.6.3-3_armhf.deb
  to main/g/gnat-4.6/gnat-4.6_4.6.3-3_armhf.deb
libgnat-4.6-dbg_4.6.3-3_armhf.deb
  to main/g/gnat-4.6/libgnat-4.6-dbg_4.6.3-3_armhf.deb
libgnat-4.6_4.6.3-3_armhf.deb
  to main/g/gnat-4.6/libgnat-4.6_4.6.3-3_armhf.deb
libgnatprj4.6-dbg_4.6.3-3_armhf.deb
  to main/g/gnat-4.6/libgnatprj4.6-dbg_4.6.3-3_armhf.deb
libgnatprj4.6-dev_4.6.3-3_armhf.deb
  to main/g/gnat-4.6/libgnatprj4.6-dev_4.6.3-3_armhf.deb
libgnatprj4.6_4.6.3-3_armhf.deb
  to main/g/gnat-4.6/libgnatprj4.6_4.6.3-3_armhf.deb
libgnatvsn4.6-dbg_4.6.3-3_armhf.deb
  to main/g/gnat-4.6/libgnatvsn4.6-dbg_4.6.3-3_armhf.deb
libgnatvsn4.6-dev_4.6.3-3_armhf.deb
  to main/g/gnat-4.6/libgnatvsn4.6-dev_4.6.3-3_armhf.deb
libgnatvsn4.6_4.6.3-3_armhf.deb
  to main/g/gnat-4.6/libgnatvsn4.6_4.6.3-3_armhf.deb


Changes:
gnat-4.6 (4.6.3-3) unstable; urgency=low
 .
  * debian/README.maintainers, debian/README.gnat: update.
 .
  Merge from gcc-4.6 (4.6.3-4) unstable; urgency=low
 .
  [ Matthias Klose ]
  * Update to SVN 20120416 (r186492) from the gcc-4_6-branch.
    - Fix PR middle-end/52894, PR target/52717, PR target/52775,
      PR target/52775.
  * Update the Linaro support to the 4.6-2012.04 release.
  * Fix PR middle-end/52870, taken from the trunk (Ulrich Weigand).
    Linaro only. LP: #968766.
  * Fix ICE (regression) in Linaro gcc-4.6 (Ulrich Weigand).
    LP: #972648.
  * Don't build ARM biarch runtime libraries, now built from the
    gcc-4.7 sources.
  * Set the ARM hard-float linker path according to the consensus:
    http://lists.linaro.org/pipermail/cross-distro/2012-April/000261.html
 .
  [ Samuel Thibault ]
  * ada-s-osinte-gnu.adb.diff, ada-s-osinte-gnu.ads.diff,
    ada-s-taprop-gnu.adb.diff, gcc_ada_gcc-interface_Makefile.in.diff:
    Add ada support for GNU/Hurd, thanks Svante Signell for the patches
    and bootstrap! (Fixes: #668425).
 .
  Merge from gcc-4.6 (4.6.3-3) unstable; urgency=low
 .
  * Update to SVN 20120406 (r186200) from the gcc-4_6-branch.
    - Fix PR c++/52796.
 .
  [ Matthias Klose ]
  * Re-add missing dependency on libgcc in gcc-multilib. Fixes: #667519.
  * Add support for GNU locales for GNU/Hurd (Svante Signell).
    Fixes: #667662.
  * Reenable the spu build on ppc64. Fixes: #664617.
  * Apply proposed patch for PR52894, stage1 bootstrap failure on hppa
    (John David Anglin). Fixes: #667969.
 .
  [ Nobuhiro Iwamatsu ]
  * Fix cross build targeting sh4. Fixes: #663028.
  * Enable -mieee by default on sh4. Fixes: #665328.
 .
  Merge from gcc-4.6 (4.6.3-2) unstable; urgency=low
 .
  * Update to SVN 20120403 (r186115) from the gcc-4_6-branch.
    - Fix PR target/52698, PR middle-end/51200, PR middle-end/52693,
      PR target/52741, PR target/52736, PR regression/52696,
      PR middle-end/51737, PR middle-end/52640, PR middle-end/48600,
      PR pch/45979, PR rtl-optimization/52528, PR Bug middle-end/50232,
      PR target/51871, PR target/50310, PR target/52408, PR target/52425,
      PR tree-optimization/50031, PR tree-optimization/50969,
      PR fortran/52469, PR fortran/52452, PR libstdc++/52433,
      PR boehm-gc/52179, PR target/49461.
 .
  [ Matthias Klose ]
  * Merge from gnat-4.6 4.6.3-1:
  * debian/control.m4: remove dependencies on ada-compiler which is being
    phased out.
  * debian/patches/ada-libgnatvsn.diff (gnatvsn.ads): new hunk, revert an
    upstream change to Current_Year to preserve the aliversion.
  * Include -print-multiarch option in gcc --help output. Fixes: #656998.
  * Re-add build dependency on doxygen.
  * Stop building runtime packages now built by gcc-4.7.
  * Stop building gccgo-4.6, predating the Go language version 1.
  * Drop the 4.6.2 symlink.
  * Always configure with --enable-gnu-unique-object. LP: #949805.
  * Fix ARM ABI conformance regression, taken from trunk/Linaro.
 .
  [ Samuel Thibault ]
  * Apply hurd-fixes.diff on hurd-any.
  * debian/patches/ada-bug564232.diff: Enable on hurd too.
  * debian/patches/ada-libgnatprj.diff: Add hurd configuration.


Override entries for your package:
gnat-4.6-base_4.6.3-3_armhf.deb - optional libs
gnat-4.6_4.6.3-3_armhf.deb - optional devel
libgnat-4.6-dbg_4.6.3-3_armhf.deb - extra debug
libgnat-4.6_4.6.3-3_armhf.deb - optional libs
libgnatprj4.6-dbg_4.6.3-3_armhf.deb - extra debug
libgnatprj4.6-dev_4.6.3-3_armhf.deb - optional libdevel
libgnatprj4.6_4.6.3-3_armhf.deb - optional libs
libgnatvsn4.6-dbg_4.6.3-3_armhf.deb - extra debug
libgnatvsn4.6-dev_4.6.3-3_armhf.deb - optional libdevel
libgnatvsn4.6_4.6.3-3_armhf.deb - optional libs



Thank you for your contribution to Debian.


Reply to: