[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#609665: libgcj10: please provide ABI virtual package

Package: libgcj10
Version: 4.4.5-9
Severity: normal

Please provide a virtual package that encodes the version of the ABI
for .jar.so files (native object code versions of .jar files for
faster execution). This would allow packages that ship such files to
depend against the "right" version of gcj/gij/...

Or otherwise give such packages a way to depend against the right
version of gcj/gij/...

See for example bug #609657 for a package that would greatly benefit
from this.

-- System Information:
Debian Release: squeeze/sid
  APT prefers stable
  APT policy: (500, 'stable'), (200, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_LU.UTF-8, LC_CTYPE=fr_LU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libgcj10 depends on:
ii  gcj-4.4-base           4.4.5-9           The GNU Compiler Collection (gcj b
ii  libasound2             1.0.23-2.1        shared library for ALSA applicatio
ii  libc6                  2.11.2-7          Embedded GNU C Library: Shared lib
ii  libgcc1                1:4.3.2-1.1       GCC support library
ii  libgcj-common          1:4.4.5-2         Java runtime library (common files
ii  libgmp3c2              2:4.2.2+dfsg-3    Multiprecision arithmetic library
ii  zlib1g                 1: compression library - runtime

Versions of packages libgcj10 recommends:
ii  gcj-4.4-jre-lib               4.4.5-9    Java runtime library for use with 

Versions of packages libgcj10 suggests:
ii  libgcj10-awt                  4.4.5-9    AWT peer runtime libraries for use
pn  libgcj10-dbg                  <none>     (no description available)

-- no debconf information

Reply to: