[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gfortran-4.3 the default gfortran compiler, blas and lapack uploaded to unstable

I did have a look at Camm's packages on p.d.o., fixed some obvious
things and uploaded those to unstable; Camm did change all package
names and the soname of all libraries, such that these packages do not
conflict with the existing packages in unstable, therefore the
decision to upload those to unstable.

An updated atlas package is uploaded to experimental; the packages
currently in the NEW queue can be found at http://people.debian.org/~doko/tmp/

The packages were built using gfortran-4.3 to avoid another
transition/rebuild for the libgfortran2/libgfortran3 change.  You
should build-depend on gfortran (>= 4:4.3) now.

The blas, lapack and atlas packages currently explicitely use the
versioned compiler version; this change can be dropped for the next

After seeing the pain in the atlas packaging, I did bump the gfortran
default compiler to 4.3 (no, I don't understand it yet, nor the reason
why the build system uses a replay of a recorded build).

current known TODO's are:

 - use the unversioned compiler again for all of blas, lapack, atlas.

 - don't use -ffloat-store in the blas build (currently ix86 only)

 - update lapack to 3.1


Reply to: