[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Friends cannot be protected or private

On Mon, Sep 26, 2005 at 11:18:56AM -0500, Adam Majer wrote:
> Hi all,
> I'm not on the list so please cc me any replies.
> I've noticed that friends cannot be protected or private anymore with
> g++-3.4 and g++-4.0. Is this the correct behaviour? Why?

Yes, this is a correctness fix.  I'm afraid I don't know enough about
C++ to explain why, but you can find a number of explanations in the
gcc list archives.

Daniel Jacobowitz
CodeSourcery, LLC

Reply to: