[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cherche noyau d'install pour D-Link



On Wed, Feb 25, 1998 at 12:27:02AM +0300, Laurent PICOULEAU wrote:

> Excuse moi, j'ai été un peu trop avare en détails :

	Heu, oui et non, j'ai fini par trouver tout seul. Ça marche
depuis hier soir. Merci à tous ;-). En fait, au fur et à mesure que
je guérri de ma grippe, je retrouve mes capacités et je m'en sort.
Maintenant, j'ai réussit à faire marcher le réseau, tout va 
(presque) bien...

> Oui, mais j'ai omis de signaler qu'il faut inclure le support de :
>   - ramdisk 
>   - minix (pour monter root.bin en tant que fs)
>   - msdos pour lire la diquette rescue (drivers aussi je crois)
>   - loop (utilisé lors du décompactage de base_1_3.tgz

	Par tatonnement, j'y suis arrivé. Le document sur les
boot-disks de Debian n'est pas très clair, et nécessite d'avoir
déjà une débian (plus ou moins). Mais bon. J'ai qu'à pas avoir
une carte à la con aussi (j'ai pas choisit :( ).

> Tu peux fouiller dans les répertoires hamm et bo-unstable pour voir si il n'y
> a pas une version plus récente. Tu peux également signaler via le système
> de remontée des bugs de debian que les disquettes d'install standards ne
> t'ont pas permis de conduire l'installation de debian avec une carte D-link,
> il en sera probablement tenu compte pour une version ultérieure.

	En fait, même avec les disquettes de la hamm, j'ai du charger
le module à la main. C'est un peu limite quand-même. Si on regarde les
docs type Ethernet HowTo, cette carte est théoriquement bien supportée.
Je n'exclut pas un problème hardware, mais je n'y connais rien...

> ??? Qu'est-ce que tu nous a fait ??? 

	C'est les biologistes, ça, ça essaie tout et n'importe-quoi
jusquà ce que ça marche. En fait, le Bios a pris un j'ton, il était
un peu dans les choux. Ça va mieux maintenant.

> >alleï, une Guinness et on repart pour la Deb.
> 
> Ha, enfin un plan simple et bon.

	Oui, et qui marche ;-).

> 03:06 est le petit nom sous lequel le noyau connait /dev/hda6. Vu le
> message d'erreur tu es en train d'esayer de monter comme partition
> racine /dev/hda6 qui soit ne comporte pas de fs, soit un fs non 
> supporté par le noyau soit n'existe pas.

	Oui, un rdev et un lilo -b ont résolut mes derniers
problèmes. Reste à me refaire un noyau qui reconnaisse du premier
coup la carte ethernet. Rien d'impossible.

> Accroches toi, debian en vaut le coup. N'hésites pas à me demander
> des éclaircissements sur mes écrits : il m'arrive d'être trop elliptique
> dans mes explications.

	C'est bon, c'est bon... C'est vrai qu'elle est bien organisée.
La base est chouette, propre (je sais pas si ça vient du POSIX ou
du FSSTND, mais je trouve tout du premier coup).

> P.S. : comme je suppose que tu n'apprécies pas plus que moi les emails
> en double, je ne réponds qu'à debian-french.

	Pareil alors.

	Bon, la question qui tue, maintenant. Je veux donc maintenant 
installer X et tout le reste. Je lance dselect, et je veux aller
chercher tout ça chez Rémy. Je choisis ftp, il me prévient que 
c'est expérimental, et là, plouf :
---
Can't locate loadable object for module IO in @INC (@INC contains: 
/usr/lib/perl5/i386-linux/5.004 /usr/lib/perl5 /usr/local/lib/site_perl/
i386-linux /usr/local/lib/site_perl .) at /usr/lib/perl5/i386-linux/5.004/
IO/Handle.pm line 248
BEGIN failed--comilation aborted at /usr/lib/perl5/i386-linux/5.004/IO/
socket.pm line 117.
BEGIN failed--compilation aborted at /usr/lib/perl5/Net/FTP.pm line 18.
BEGIN failed--compilation aborted at /usr/lib/dpkg/methods/ftp/setup line 7.

query/setup script returned error exit status 2
Press RETURN to continue
---

	J'ai recopié, ne faites pas attention aux eventuels typos. Je vais 
essayer de trouver ce que ça veut dire, mais je ne suis pas un 
spécialiste du perl. À la ligne 248 de Handle.pm, il y a :

bootstrap IO $XS_VERSION

	Je trouve $XS_VERSION au début (ligne 202, mais c'est bien
les définitions, c'est très documenté, bref, incompréhensible ;-).

use vars qw($VERSION $XS_VERSION @EXPORT_OK $AUTOLOAD @ISA);
(...)
$XS_VERSION = "1.15"

	Qu'est-ce qu'il veut? J'ai peur qu'il essaie de reconnaitre
la carte par lui même. En fait, il me manque peut-être le module
ISA puisque en 247, j'ai @IO::ISA hors je n'ai pas de ISA.pm
dans le dossier IO (un oubli de la base?). Je me trompe peut-être,
je vais essayer de voir déjà ça.
						François.

P.S.: Je vais demander sur fr.comp.lang.perl aussi, on verra...
-- 
François Jeanmougin     | groupe de bioinformatique / bioinformatics group
tel:(+33) 3 88 65 32 71 | IGBMC BP 163 67404 Illkirch France


--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-french-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .


Reply to: