[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Freedombox-discuss] Booting Guruplug with self-built image

On Wed, 18 Jul 2012 12:30:58 +0400, Markus Sabadello <markus.sabadello at gmail.com> wrote:
> So with a recent and clean Debian Wheezy, I was able to run freedom-maker
> (latest version from Nick's repository), however I still had a few issues..
> Running freedom-maker under Debian Squeeze didn't work at all for me, lots
> of errors, only Wheezy worked.

Odd, I build it on a Squeeze system.

> Glad to see the projects-chroot.sh reference in bin/finalize was changed to
> projects-chroot, that had also confused me in the past :)
> I still had to manually copy the kernel/uInitrd file to /boot, I don't know
> why freedom-maker doesn't copy it.

That's fixed, sorry.

> I WAS finally able to boot my Guruplug with the self-built image on a USB
> stick:
> ...
> However I am still not sure if the image built correctly after all, e.g. I
> got the following when trying to start Plinth:
> $ ./plinth.py
> Traceback (most recent call last):
>   File "./plinth.py", line 6, in <module>
>     import cfg
> ImportError: No module named cfg
> Which makes me wonder if my self-built image is okay, or if something went
> wrong.
> Is Plinth supposed to start automatically when the FreedomBox boots, or do
> you have to start it manually?

For now, you still need to ``make`` it, first.  I think that's in
Plinth's README.  I've been meaning to make it do that while building
the image, but haven't had a chance.  You can look in the
freedom-maker/projects and freedom-maker/projects-chroot files if you're

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 835 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20120718/76796e29/attachment.pgp>

Reply to: