[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Freedombox-discuss] Booting Guruplug with self-built image

So with a recent and clean Debian Wheezy, I was able to run freedom-maker
(latest version from Nick's repository), however I still had a few issues..

Running freedom-maker under Debian Squeeze didn't work at all for me, lots
of errors, only Wheezy worked.

Glad to see the projects-chroot.sh reference in bin/finalize was changed to
projects-chroot, that had also confused me in the past :)

I still had to manually copy the kernel/uInitrd file to /boot, I don't know
why freedom-maker doesn't copy it.

I WAS finally able to boot my Guruplug with the self-built image on a USB

usb start
fatload usb 0:1 0x800000 uImage
 fatload usb 0:1 0x1100000 uInitrd
setenv bootargs root=/dev/sda2
bootm 0x800000 0x1100000

The boot process was extremely fast and didn't output anything until the

## Booting kernel from Legacy Image at 00800000 ...
   Image Name:   Debian kernel 3.0.0-kirkwood
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2733148 Bytes = 2.6 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 01100000 ...
   Image Name:   Debian ramdisk 3.0.0-kirkwood
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    2455604 Bytes = 2.3 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

Debian GNU/Linux wheezy/sid freedombox ttyS0

freedombox login:

However I am still not sure if the image built correctly after all, e.g. I
got the following when trying to start Plinth:

$ ./plinth.py
Traceback (most recent call last):
  File "./plinth.py", line 6, in <module>
    import cfg
ImportError: No module named cfg

Which makes me wonder if my self-built image is okay, or if something went

Is Plinth supposed to start automatically when the FreedomBox boots, or do
you have to start it manually?

I'm attaching my output of the freedom-maker script, in case anyone is

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20120718/b6cc1e15/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: out.gz
Type: application/x-gzip
Size: 739876 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20120718/b6cc1e15/attachment-0001.bin>

Reply to: