[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Pkg-fonts-devel] Possible abuse of dpkg-deb -z9 for xz compressed binary packages



2014-09-01 21:20 GMT+09:00 Guillem Jover <guillem@debian.org>:
> There seems to be some packages overriding the default compression
> level for xz to 9. This means dpkg-deb will require way more memory on
> both compression and decompression usually for extremely little gain,
> and might even fail on some systems with low memory (see #757740 for
> an example). But the real issue is that (as mentioned on the xz man
> page), using such high levels might actually make no sense at all
> when being using with data that is smaller than the dictionary size.
>
> From doing a quick search on <http://codesearch.debian.net/> for
> “dpkg-deb.*-z9” and “dh_builddeb.*-z9”, but w/o looking in detail, it
> seems that most packages are or have been maintained by Daniel Baumann
> or the Fonts Team (both CCed). Was there an actual reason to use -z9,
> beside maybe trying to get the “bestest” compression possible? :)

"dh_builddeb -- -Zxz -Sextreme -z9" has been introduced to the
pkg-font team when dpkg-deb default is not xz.

In my quick experiments with some font packages, "-Sextream -z9"
option still gives  ~4% smaller size than the default. IMO this is
still significant for big font packages.



Reply to: