[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Internet stops working right after startup


While i'm not entirely sure im gona say segfault = bad.

What kernel are you running? have you tried a newer version?
And have you tried another nic?

Frank Razenberg wrote:
Hi Mark,

The route does not change after this. I use "ifdown eth0" and "ifup eth0" but "/etc/init.d/networking restart" works as well.

I monitored dmesg and found this:

   [  422.079991] EXT3 FS on sda1, internal journal
   [  422.483633] loop: module loaded
   [  423.039841] ip_tables: (C) 2000-2006 Netfilter Core Team
   [  423.055658] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
   [  423.093037] ifup[5845]: segfault at 0 ip 7fbd4bce9882 sp
   7fff541b78d0 error 4 in libc-2.7.so[7fbd4bc4b000+14a000]
   [  426.970376] NET: Registered protocol family 10
   [  426.974379] lo: Disabled Privacy Extensions
   [  427.134712] ifup[5939]: segfault at 0 ip 7fbd4bce9882 sp
   7fff541b78d0 error 4 in libc-2.7.so[7fbd4bc4b000+14a000]
   [  427.152782] r8169: eth1: link up

I think this means some program crashes and eth0 is not brought up correctly. I have no idea why it does work if I try again though. Any further tips?


Mark Chong wrote:

Does the output of ifconfig and route -n change after you take down eth0 and bring it up again?
also how are you taking it down and bring it up again?

dmesg will show you if for some reason you lost your link

Frank Razenberg wrote:

I've attached the logs Mark asked for. I removed all iptables rules but the ones to allow ip masquerading. The problem still persists. I can ping the internal hosts just fine though. The only thing that seems to solve this is to bring down eth0 and bring it up again. Are there any logs I can read to help identify this problem?


Ajitabh Pandey wrote:

2009/1/21 Frank Razenberg <frank@zzattack.org <mailto:frank@zzattack.org>>

    Hi Ajitabh,

    I attached the information you asked. Apologies for the mail I
    just sent to your address instead of to the mailing list.


Thanks for the info. Although this has nothing to do with your problem, but check your config of the INPUT chain. All incoming connections are allowed. Also, to rule out the firewall completely, just drop your firewall for the testing and see whether you have problems.

Also when this problem happens, can your internal hosts ping the Debian machine or connect to it?

--  Ajitabh Pandey
http://www.ajitabhpandey.info/ | http://www.unixclinic.net/
ICQ - 150615062
Registered Linux User - 240748

Reply to: