[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

firmware hotplug problem

Hello all!
I've recently setted up a firewall-router with an adsl connection via a hamlet 640s usb modem. The modem doesn't cause me trouble if I hotplug it, but if I cold plug it the accessrunner driver can't find the firmware:

cxacru 1-2:1.0: firmware unavailable (hotplug configuration problem?)

Now, the issue is that for security reasons I disabled the modules in the kernel, so every time I boot up the firewall I have to disconnect and then reconnect the modem by hand to make it find the firmware. That's quite uncomfortable, since the firewall is in a place not really easy to reach.

Has anyone suggestions to solve my issue?
I've searched in the archives without luck :(

I add that I run debian sarge, with a custom (obviously) 2.6.10 kernel on a pentium 133 with a 1.3 Gb HD

proc            /proc           proc     defaults        0       0
/dev/hda1       /               reiserfs notail          0       0
/dev/hda2       /home           xfs      defaults        0       0
/dev/hdc        /media/cdrom0   iso9660  ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto     rw,user,noauto  0       0

thanx for any suggestion

PS. I tried adding the firmware into an initrd, without success.

Reply to: