[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Jessie cross compiling via emdebian broken

On Wed, Mar 06, 2019 at 10:06:31AM -0800, Kris Bahnsen wrote:
> [....]
> We have a specific need for Debian Jessie cross compiling on x86
> host to armhf target. Previously, these instructions worked:
> https://wiki.debian.org/CrossToolchains#For_jessie_.28Debian_8.29
> Which pulled in emdebian packages to provide the actual cross
> compilers.
> Currently, the steps outlined there are completely broken when using
> a fresh Debian Jessie installation:

> root@debian-testingcc:/home/karl# apt-get install crossbuild-essential-armhf
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>  crossbuild-essential-armhf : Depends: gcc-arm-linux-gnueabihf (>=
> 4.9.1-1) but it is not going to be installed
>                               Depends: g++-arm-linux-gnueabihf (>=
> 4.9.1-1) but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.

Hi Kris,

In the dependency chain for gcc-arm-linux-gnueabihf and friends
from the emdebian.org/tools/debian repo there are dependencies
with strict version requirements on packages in the official
Jessie repositories---e.g., libgcc-4.9-dev:armel (= 4.9.2-10).
Eventually, some of those packages in Jessie were updated in
point and security releases---e.g., to 4.9.2-10+deb8u2. The
packages in emdebian.org/tools/debian didn't get updated,
however, hence the error you're seeing.

If you download the relevant source package, cross-gcc-4.9-armhf
and perhaps a few others, from emdebian.org/tools/debian and
rebuild against the latest point release of Jessie (perhaps
with security updates too), you'll eventually get a set of
packages that will work on the version of Jessie against which
you build. Alternatively, I suppose, you could install an older
point release of Jessie and use the packages from
emdebian.org/tools/debian as-is.

Good luck.
-- Ryan

Reply to: