[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian Jessie cross compiling via emdebian broken

Been hoping this would resolve itself for a little while but have not seen any changes.

We have a specific need for Debian Jessie cross compiling on x86 host to armhf target. Previously, these instructions worked: https://wiki.debian.org/CrossToolchains#For_jessie_.28Debian_8.29 Which pulled in emdebian packages to provide the actual cross compilers.

Currently, the steps outlined there are completely broken when using a fresh Debian Jessie installation: root@debian-testingcc:/home/karl# echo 'deb http://emdebian.org/tools/debian/ jessie main' > /etc/apt/sources.list.d/crosstools.list root@debian-testingcc:/home/karl# curl http://emdebian.org/tools/debian/emdebian-toolchain-archive.key | apt-key add -   % Total    % Received % Xferd  Average Speed   Time Time     Time  Current
                                 Dload  Upload   Total Spent    Left  Speed
100  2398  100  2398    0     0   6727      0 --:--:-- --:--:-- --:--:--  6717
root@debian-testingcc:/home/karl# dpkg --add-architecture armhf
root@debian-testingcc:/home/karl# apt-get update
Get:8 http://emdebian.org jessie/main armhf Packages [7,623 B]
Ign http://emdebian.org jessie/main Translation-en_US
Ign http://emdebian.org jessie/main Translation-en
Hit http://ftp.us.debian.org jessie/main Translation-en
Fetched 7,396 kB in 5s (1,356 kB/s)
Reading package lists... Done
root@debian-testingcc:/home/karl# apt-get install crossbuild-essential-armhf
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 crossbuild-essential-armhf : Depends: gcc-arm-linux-gnueabihf (>= 4.9.1-1) but it is not going to be installed                               Depends: g++-arm-linux-gnueabihf (>= 4.9.1-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Is there any way to get this resolved? Any known workarounds? I've attempted to manually install all of the packages but I have been unable to get a proper cross compiler fully installed. I'm not sure exactly how long this situation has existed but at one point in time it has worked.

Best Regards,
Kris Bahnsen, Technologic Systems     | voice: (480) 837-5200
16525 East Laser Drive                | fax: (480) 837-5300
Fountain Hills, AZ 85268              | web: www.embeddedARM.com

Reply to: