[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unmet dependencies problem in CrossToolchains

+++ Oleg Popkov [2015-01-15 23:16 +0100]:
>    Hello all,
>    I tried to install crosstoolchain packages for arm and powerpc
>    architectures on GNU/Linux 7.7 (wheezy) distro with kenel debian
> #1 SMP Debian 3.2.63-2+deb7u2 i686 GNU/Linux. Here is a
>    list of command sequence I used, this manual I took from [1]here.
>    debootstrap sid sid
>    chroot sid
>    Added "deb [2]http://emdebian.org/tools/debian/ jessie main" in
>    "/etc/apt/sources.list"

ah - you debootstrapped sid, then tried to use jessie
crosstoolchains. That won't work (libgcc/libc versions won't match up)

Try using either jessie chroot (more reliable), or sid toolchains
(currently fine, but new gcc uploads can cause breakage until matching
cross-toolchains are built).

>    curl [3]http://emdebian.org/tools/debian/emdebian-toolchain-archive.key
>    |apt-key add -
>    dpkg --add-architecture powerpc
>    dpkg --add-architecture armel
>    sudo apt-get update
>    Everything goes fine untill the moment I want to install
>    crossbuild-essential-armhf package, the command
>    apt-get install crossbuild-essential-armhf

OK. In a jessie chroot this works fine for powerpc and armel, except for one
detail. dpkg-cross has been removed from jessie due to RC bugs, so
crossbuild-essential-* is uninstallable. You have to do
sudo apt-get install libc6-dev:armel gcc-arm-linux-gnueabi g++-arm-linux-gnueabi
sudo apt-get install libc6-dev:powerpc gcc-powerpc-linux-gnu  g++-powerpc-linux-gnu

I forgot that we still needed dpkg-cross in jessie for this. I'll see
if it can be fixed/re-instated. If not it'll have to live in the
emdebian repo to make things work.

OK. I've uploaded dpkg-cross_2.6.11~emdeb8 to the emdebian repo to fix
this problem for now. That can go away again if we get a better

So now
sudo apt-get install crossbuild-essential-powerpc
sudo apt-get install crossbuild-essential-armel
works fine.

>    What did I do wrong? How could I satisfy missing dependencies?? Thank you
>    in advance.

You need to use matching chroot and tools suites. 

Principal hats:  Linaro, Debian, Wookware, ARM

Reply to: