[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

device-table.pl: devices nodes are simple files

Hi! Just before I start, two notes:
- I may be missing something.
- I don't speak perl :-)

On trying device-table.pl I found that instead of device nodes I got simple 
files as output.

I have tried running as a normal user and as root, in both cases with and 
without fakeroot (even if it should not be necessary while using root).

So I decided to take a look to the script. I found that running a line like 
device-table.pl::120 with fakeroot will create simple files, while running 
them as root they were proper device nodes.

I then commented out lines [41-43] and 45. This time the script worked. Of 
course, I ran it as root.

[further reading the script]

And reading further I found the --no-fakeroot option. Also works as expected. 
I can make patches for the documentation to show this option.

Kind regard, Lisandro.

En los momentos de crisis, la imaginación es mas importante que el 
 Albert Einstein

Lisandro Damián Nicanor Pérez Meyer

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: