[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Question about Multistrap

In my local repository, instead of pulling in the dependencies for the
latest package, multistrap kind of goes through all the versions of
available package and throws out an error saying the dependencies were
not met.

This is what I'm getting. I have a single meta package which pulls in
all the dependencies it needs and for example libdbixx0-dev is not in
the dependency tree for my meta package


The following packages have unmet dependencies:
  libdbixx0-dev: Depends: libdbixx0 (=
0.0.3kal1-1.20100418.030553.0bef81f) but
0.0.3kal1-1.20100628.124113.d9904bd is to be installed
  libksettings1-dev: Depends: libksettings1 (=
0.0.0-1.20100418.030847.b729848) but 0.0.0-1.20100430.031002.4173846
is to be installed
  xlibs: Conflicts: xorg-conf
  xorg-startup: Conflicts: wmakerstartup-conf
E: Broken packages
apt download failed. Exit value: 100

With Best Regards,
Vivek Raghunathan

With Best Regards,
Vivek Raghunathan

On Thu, Aug 5, 2010 at 10:15 PM, Wookey <wookey@wookware.org> wrote:
> +++ Vivek Raghunathan [2010-08-05 18:23 -0700]:
>> Also, is there a way to let multistrap use a specific version of the
>> package (specify the version along with the name of the package?)
> Multistrap uses apt, so you should be able to use package pinning to
> specify a particular version, but I'm not sure that ther is any way of
> specifying such extra apt options in the multistrap config.
> We have always dealt with package selection by making sure that the
> package we want it to use has the highest version (normally the ones
> in our local repo).
> Can you explain why you need this functionality?
> Wookey
> --
> Principal hats:  Linaro, Emdebian, Wookware, Balloonboard, ARM
> http://wookware.org/

Reply to: