[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

sh support in dpkg-cross

Im playing with sh3. I already got a toolchain that seems to work, but
I cant figure out how to make dpkg-shlibdeps work. As I built a
toolchain for mipsel in parallel with the sh3 toolchain Im pretty sre
that the problem is not with the toolchain but with dpkg-cross or
Building expat fails likethisfor sh3:
dh_shlibdeps -a -l /mnt/quitte/sh3linux/expat-1.95.8/debian/libexpat1/usr/lib
dpkg-shlibdeps: failure: couldn't find library libgcc_s.so.1 needed by
debian/libexpat1/usr/lib/libexpat.so.1.0.0 (its RPATH is '').
Note: libraries are not searched in other binary packages that do not
have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to set
dh_shlibdeps: command returned error code 512
make: *** [binary-arch] Error 1
dpkg-buildpackage: failure: debian/rules binary gave error exit status 2

I tried adding sh3 support to dpkg-cross archdetecttable and
crossprefixtable like this:
'sh' => 'ELF 32-bit LSB .* Renesas SH',
and this:;
"sh3" => [ "sh3-linux-gnu-", "sh3-linux-gnu-", "sh3-linux-",
"sh3-linux-", "sh3-gnu-", "sh3-gnu-" ],

I also tried a few variations, but never got it to work.
best regards,

Reply to: