[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Problems building gcc-4.1 from etch testing. 'debian/rules control' fails because no FFI or GFDL files in

Hello Jim,

If it helps I ran into same error, and Wartan also. So, it might need to be fixed some how.


2006/10/5, Jim Heck < Jim.Heck@sun.com>:

Thanks for the reply.  On closer look, I was attributing the failure of
'dpkg-buildpackage' to the benign errors in the 'debian/rules control'
script as you pointed out.

Instead, my problem was with unmet dependencies to build gcc, specifically,

dpkg-buildpackage: source package is gcc-4.1
dpkg-buildpackage: source version is 4.1.1ds1-13
dpkg-buildpackage: source changed by Matthias Klose <doko@debian.org>
dpkg-buildpackage: host architecture i386
dpkg-buildpackage: source version without epoch 4.1.1ds1-13
dpkg-checkbuilddeps: Unmet build dependencies:
libc6-dev-ppc64-powerpc-cross (>= 2.3.6-7)
dpkg-buildpackage: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: (Use -d flag to override.)

I installed crosses of the following libraries to fill in the missing


Now dpkg-buildpackage doesn't complain about dependencies, but still
fails to build due to

checking for libintl.h... yes
checking for library containing gettext... configure: error: Link tests
are not allowed after GCC_NO_EXECUTABLES.
make[3]: *** [configure-target-libstdc++-v3] Error 1
make[3]: Leaving directory `/usr/src/cross-toolchain/gcc-4.1-4.1.1ds1/build'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/src/cross-toolchain/gcc- 4.1-4.1.1ds1/build'
s=`cat status`; rm -f status; test $s -eq 0
make[1]: *** [stamps/05-build-stamp] Error 1
make[1]: Leaving directory `/usr/src/cross-toolchain/gcc-4.1-4.1.1ds1'
make: *** [stamps/05-build-stamp] Error 2

Some searching around the web brought me to these bug reports


which deal with a change to binutils dealing with some form of 64 bit
patch.  The binutils I have is later than the one specified as fixed,
but to my eye the fix seemed like it might be specific to amd64 bit

Would you happen to know if I am simply missing some additional cross
library that handles 'gettext', or if the bug report I found for
binutils also applies to ppc64 in some currently unpatched way.  I'm
wondering if there is a way I could just build without the 64bit PPC
support alltogether, as I don't need it.  Any additional help you could
give to get me further along would be greatly appreciated.

Thanks for the help,

-Jim Heck

To UNSUBSCRIBE, email to debian-embedded-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: