[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#987683: crashes with "Wrong type argument: (or eieio-object class), nil, obj"

Ср 28 апр 2021 @ 08:50 Antoine Beaupré <anarcat@debian.org>:

> Control: severity -1 normal
> On 2021-04-28 09:00:46, Lev Lamberov wrote:
>> Hi Antoine,
>> Вт 27 апр 2021 @ 13:53 Antoine Beaupre <anarcat@debian.org>:
>> I have elpa-esup installed for a long time and I cannot reproduce the
>> bug on my machine. Running esup starts another GNU Emacs session and
>> gives me a proper report on startup like the following excerpt:
> Oh interesting! Maybe that's why it works, since the bytecode is older?

Well, each update of GNU Emacs and at least sometimes updates of dh-elpa
trigger recompilation of all installed packages. On my machine file
/usr/share/emacs/site-lisp/elpa/esup-0.7.1/esup.elc starts with

;;; Compiled
;;; in Emacs version 27.1
;;; with all optimizations.

That is, it was recompiled at least with installation of GNU Emacs 27.1,
which was first uploaded to unstable on 2020-10-24, but I still remember
that there were more recompilation of all installed packages recently
(probably, even on 2021-04-07 when Emacs 1:27.1+1-3.1 entered testing).

>> ```
>> Total User Startup Time: 0.357sec     Total Number of GC Pauses: 3     Total GC Time: 0.065sec
>> package.elc:16  0.134sec   37%
>> (byte-code "\301\302!\210\301\303!\210 [...]
>> ```
>> I wonder how recompiling could fix the problem you face, since
>> installing/reinstalling the package or GNU Emacs itself should trigger
>> recompilation of it along with all other installed Emacs packages.
> Yeah, as I said I haven't tried to recompile myself, that's just what
> the upstream bug report says. If anything, maybe it's the opposite and
> if *you* recompile you'll trigger the bug? No idea.

I've tried to reinstall elpa-esup, which caused recompilation and still
I cannot reproduce your bug both with my config and with emacs -q.

>> So, may it be a bug in dh-elpa or GNU Emacs itself?
> Maybe! This is way beyond my elisp-fu unfortunately.
> One key information I have just discovered is that I can't reproduce
> with `emacs -q`. So this is probably an interaction with my .emacs.d
> configuration and the package, unfortunately. Downgrading severity.

It makes it a bit trickier. There another package, elpa-bug-hunter
[elpa-bug-hunter], which automatically debug and bisect your init.el or
.emacs file. It may be worth t try it with your config.

[elpa-bug-hunter] https://tracker.debian.org/pkg/elisp-bug-hunter


Reply to: