[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

emacs kill ring and X

X has a cut and paste buffer that you can use with the mouse. But using the
mouse is much less convenient than using the keyboard. Years ago, emacs under
X added a mechanism that linked its kill ring with the X cut and paste buffer.
Since the dawn of emacs, one was able to use something like M-w to put
something into the kill ring and C-y to put something from the kill ring into
the buffer. And this worked across emacs "windows" (C-x 2) that were in the
same X window. But the mechanism added years ago was that you could have two
different emacs processes (even on different machines) in two different X
windows and M-w from one and C-y to the other because M-w not only put text
into the kill ring, it also put it in the X cut and paste buffer, and C-y not
only took stuff out of the kill ring, it also took stuff out of the X cut and
paste buffer.

This has worked for decades.

Now I have emacs 23.4.1 on Debian wheezy

  "GNU Emacs 23.4.1 (x86_64-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
   of 2012-09-08 on trouble, modified by Debian"

and emacs 24.3.1 on Ubuntu 14.04.3 LTS.

  "GNU Emacs 24.3.1 (x86_64-pc-linux-gnu, GTK+ Version 3.10.7)
   of 2014-03-07 on lamiak, modified by Debian"

I can M-w from the latter and C-y to the former just fine. But I can't M-w
from the former and C-y to the latter. Why? I think it is the
difference between the X toolkit version of emacs and the GTK+ version of emacs
I remember that under Debian there are two different emacs packages and I had
to select emacs23-lucid to get the non-GTK version to get this to work.

qobi@thakaa>dpkg --get-selections '*'|fgrep emacs
emacs-goodies-el                                install
emacs23-bin-common                               install
emacs23-common                                   install
emacs23-el                                       install
emacs23-lucid                                    install
emacsen-common                                   install

Is there a way to get this to work with the GTK version?

    Jeff (http://engineering.purdue.edu/~qobi)

Reply to: