[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unable to load html helper mode--error

This error message first appeared when I added html helper to my
wintel laptop.

	file mode specification error:  (invalid-read-syntax ")")

Since my desktop wintel worked just fine, I figured for a typo.  So, I
copied my .emacs file to a floppy, then to the laptop.  This fixed the

Now the desktop is showing the same error!!!

Here is the .emacs file:

(setq default-major-mode 'text-mode)
(add-hook 'text-mode-hook 'turn-on-auto-fill)
(setq load-path (cons "c:\\gnuemacs\\emacs-20.7\\lisp" load-path))
(autoload 'html-helper-mode "html-helper-mode" "Yay HTML" t)
(setq auto-mode-alist (cons '("\.html$" . html-helper-mode)
(setq html-helper-do-write-file-hooks t)
(setq html-helper-build-new-buffer t)
(setq html-helper-address-string
      "<a href \"MAILTO:kk5st@swbell.net\">Gary Turner &lt;

I'm guessing that there is a dangling parenthesis in there that my
tired old eyes just can't spot.  I just don't know where it could have
come from.

BTW both boxes were invested with emacs in identical manners.

So, when you elisp/emacs gurus stop giggling over the probably obvious
(to you) error, please hit the reply button and explain the punchline
to me.  My thanks will be effusive.


Reply to: