[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with BIOS boot partition

This question doesn't seem to have sparked too much interest...

For the record I managed to track the source of the hang while booting to the kernel module efivarfs, which apparently doesn't handle the lack of support for EFI smoothly. Strangely enough, loading it once the system has booted works OK (at least on kernel version 4.19.0-6-amd64). Anyway blacklisting efivarfs either on the grub linux command line or in /etc/modprobe.d fixed the problem.

I also determined that the BIOS boot partition loads the EFI image <esp>/EFI/BOOT/BOOTX64.EFI which also serves as a fallback default image on native EFI support.

I've yet to solve the lack of font support in grub but I guess that isn't the business of this mailing list.


On 8/5/20 10:52 am, Jonathan Schultz wrote:

I'm hoping someone can help me boot Debian using EFI on my old Acer Travelmate. Although it does work using MBR and if all else fails I can revert to that I am hoping to make it work using EFI so I can dual boot with Windows 10 which refuses to install on an MBR partitioned drive.

The BIOS (Phoenix SecureCore Tiano version 1.23) doesn't support EFI so based on instructions here https://blog.heckel.io/2017/05/28/creating-a-bios-gpt-and-uefi-gpt-grub-bootable-linux-system/ I created a BIOS boot partition alongside an EFI partition. But I still can't get debian to boot from that hard drive, only from a second MBR partitioned drive.

So what happens?

The machine boots into a GRUB command line (despite the presence of a grub.cfg that should execute a configfile to my master grub.cfg on the debian partition). If I manually execute a configfile then it briefly displays an error warning about being unable to find /efi/boot/fonts/unicode.pf2), then the screen fills with random flecks of white and black, and then it starts booting. However it freezes with the last line saying:

...... systemd[1]: Inserted module `autofs4'

If instead of executing configfile from the GRUB command prompt I type the linux and initrd commands manually, it does exactly the same thing (minus the error code regarding ...fonts/unicode.pf2).

Thinking that the problem was the autofs4 module I tried blacklisting that module on the GRUB command line, but the boot process froze at the same spot, with the message indicating that autofs4 was blacklisted rather than installed.

Some other things I have tried include running install-grub, which creates a second sub-directory 'debian' under EFI in the efi partition. I tried chainloading grubx64.efi from that partition at the GRUB prompt, but that just froze the machine up.

I'm finding really scant documentation about how BIOS boot partitions work. For instance, which EFI image do they load? Are EFI images automatically compatible with BIOS boot partitions or do only some work? Is there anything else I need to do to my Debian installation (boots fine under MBR) so that it will boot using EFI?

Can anyone offer some pointers?

Many thanks,

Reply to: