[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#961490: fwupd: version in stable too old, no updates possible

Package: fwupd
Version: 1.2.5-2
Severity: grave
Justification: renders package unusable

Dear Maintainer,

The version 1.2.5 of fwupd currently in Debian stable is useless and not able
to perform any firmware updates.
Whem trying to update via command line:

> fwupdmgr refresh && fwupdmgr get-updates

I get the following output:

 Metadaten werden abgerufen https://cdn.fwupd.org/downloads/firmware.xml.gz
 Herunterladen …          [***************************************]
 Signatur wird abgerufen https://cdn.fwupd.org/downloads/firmware.xml.gz.asc

 Not compatible with org.freedesktop.fwupd version 1.2.5, requires >= 1.2.7

The "refresh" part still works, but the new firmware info requires a newer
version of fwupd than available in stable, so the "get-update" part fails.

I'm not sure how to best handle this situation. It's very unfortunate that
fwupd obviously breaks compatibility with older clients here...
Maybe a new version in backports would be possible?


-- System Information:
Debian Release: 10.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.5.0-0.bpo.2-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8), LANGUAGE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages fwupd depends on:
ii  libarchive13           3.3.3-4+deb10u1
ii  libc6                  2.28-10
ii  libefiboot1            37-2
ii  libefivar1             37-2
ii  libelf1                0.176-1.1
ii  libfwupd2              1.2.5-2
ii  libgcab-1.0-0          1.2-3~deb10u1
ii  libglib2.0-0           2.58.3-2+deb10u2
ii  libgnutls30            3.6.7-4+deb10u3
ii  libgpg-error0          1.35-1
ii  libgpgme11             1.12.0-6
ii  libgudev-1.0-0         232-2
ii  libgusb2               0.3.0-1
ii  libjson-glib-1.0-0     1.4.4-2
ii  libpolkit-gobject-1-0  0.105-25
ii  libsmbios-c2           2.4.1-1
ii  libsoup2.4-1           2.64.2-2
ii  libsqlite3-0           3.27.2-3
ii  libxmlb1               0.1.6-2
ii  shared-mime-info       1.10-1

Versions of packages fwupd recommends:
ii  bolt                               0.7-2
ii  fwupd-amd64-signed [fwupd-signed]  1.2.5+2
ii  python3                            3.7.3-1
ii  tpm2-abrmd                         2.1.0-1
ii  tpm2-tools                         3.1.3-2

fwupd suggests no packages.

-- no debconf information

Reply to: