[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot enter home directory. Using /.

Hi Tom

I think I've seen this before, but I can't remember what it was exactly.

NB I think the list at skolelinux.no is pretty much dead, yours is the first I've seen in months. The Debian-edu list is more active:

List-Id: <debian-edu.lists.debian.org>
List-URL: <http://lists.debian.org/debian-edu/>
List-Post: <mailto:debian-edu@lists.debian.org>
List-Help: <mailto:debian-edu-request@lists.debian.org?subject=help>
List-Subscribe: <mailto:debian-edu-request@lists.debian.org?subject=subscribe> List-Unsubscribe: <mailto:debian-edu-request@lists.debian.org?subject=unsubscribe>

I'm cc-ing that list, perhaps you'll get an answer there?



On 04/07/15 11:01, Tom Duguid wrote:

I have been struggling with a problem for a while and I cannot find a

I have a SckoleLinux server installed with the main server and
workstation options selected for install.
I have 10 workstations with SkoleLinux installed.
I made a mistake when installing some of the workstations using
sitesummary2ldap so I removed them using GOSA2.
I used 'sitesummary2ldap -a -i ether-xx:xx:xx:xx:xx:xx -t workstations'
to put the workstations back on the server.
The workstations that I had NOT added and removed previous to this
The workstations that I had added by mistake and removed previous to
this came up with the following error whenever any user attempts to log
in: 'Cannot enter home directory. Using /.'

I can recreate this on a Virtual Machine setup by adding a workstation
client to the VM server (it works at this point) and then removing it
through GOSA2 and adding it again through sitesummary2ldap. When I try
to log into the VM workstation I get the 'Cannot enter home directory.
Using /.' error again.

There is then the additional message: 'Missing user home directory
Check if the current computer DNS name is in the NIS Netgroup
workstation-hosts and authorized to mount the home directories from the
NFS server. This is done using Gosa, https://www/gosa'

The workstation is in the workstations-hosts group. This can be seen in
gosa and when running 'ldapvi'. I have checked ldapvi when the
workstation in first added then when removed then when added back. When
it is first added and added back the entries are identical. when the
workstation is removed the entries about the workstation are not there.

In the VM I have changed the workstation's MAC address and tried adding
it again but get the same error.
After I had caused the problem I returned the VM server to the point it
was before adding the workstation then added the workstation that I had
broken before. That was successful and without reinstalling the
workstation I could logon.

At the school I am installing this in I have reinstalled the server and
started again but if this happens once it is being used I would like a
way of solving the problem.

Any help would be welcome,

Tom Duguid.

admin-discuss mailing list

Reply to: