[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#669762: marked as done (debian-edu-config: transition towards Apache 2.4)



Your message dated Fri, 22 Aug 2014 16:48:40 +0000
with message-id <E1XKs12-0004k7-3r@franck.debian.org>
and subject line Bug#669762: fixed in debian-edu-config 1.720
has caused the Debian Bug report #669762,
regarding debian-edu-config: transition towards Apache 2.4
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
669762: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=669762
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-edu-config
Severity: important
User: debian-apache@lists.debian.org
Usertags: apache24webapptransition

Dear maintainer,

your package debian-edu-config is a web application which supports the Apache2
web server. We're upgrading Apache to the new upstream version 2.4 [1]
(tracked as transition bug #661958). This requires some changes in your
package about how to interface to our package. You can test your package
against our package available in experimental [2] which is soon to be
uploaded to Sid. Please note, chances are that for the time being, third
party modules (e.g. mod_php, mod_perl and such) are not yet available in
a version capable to run with the Apache 2.4 web server. You can use
their (Fast-)CGI counter parts, e.g. php5-fpm to test your packages. You
can see an up to date state of modules being in the transition to
Apache2 2.4 at [3]. We have written packaging guidelines for our reverse
dependencies [4]. Please read this document carefully, it should be able
to answer most of your questions. Do also look at dh_apache2 (available
through  the dh-apache2 package) which can simplify shipping of Apache2
configuration files. 

In short, we want to highlight these changes you need to be aware of:

* Do NOT declare a strong relation against apache2.2-common (or
 apache2-common as its natural successor). Instead recommend "apache2 |
 httpd" in your package relationships. 

* Do NOT install any files to /etc/apache2/conf.d/. This directory is
 obsolete. Its successor is /etc/apache2/conf-available/ which can be
 interfaced through a2enconf/a2disconf

* Do NOT call a2enconf/a2disconf in your maintainer scripts. Use our
 apache2-maintscript-helper [4] instead. This is required to get a
 uniform and stateful handling of all web applications interfacing with
 Apache2.

* Please use the new authentication and authorization directives of
 Apache 2.4 [6]. While the old style directives are in principle still
 supported using mod_access_compat, mixing old and new style directives
 can cause problems. Moreover, the compatibility mode may be removed in
 a future release.


You can look at our Apache 2.4 packaging hints [7] for hands-on
tutorials.



[1] https://lists.debian.org/debian-devel-announce/2012/03/msg00013.html
[2] http://packages.debian.org/search?keywords=apache2&searchon=sourcenames&exact=1&suite=all&section=all
[3] http://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=apache24transition;users=debian-apache@lists.debian.org
[4] http://anonscm.debian.org/gitweb/?p=pkg-apache/apache2.git;a=blob;f=debian/PACKAGING;hb=next
[5] http://httpd.apache.org/docs/2.4/developer/new_api_2_4.html
[6] http://httpd.apache.org/docs/2.4/upgrading.html#run-time
[7] http://wiki.debian.org/Apache/PackagingFor24





--- End Message ---
--- Begin Message ---
Source: debian-edu-config
Source-Version: 1.720

We believe that the bug you reported is fixed in the latest version of
debian-edu-config, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 669762@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Petter Reinholdtsen <pere@debian.org> (supplier of updated debian-edu-config package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 22 Aug 2014 18:34:53 +0200
Source: debian-edu-config
Binary: debian-edu-config debian-edu-config-gosa-netgroups
Architecture: source all
Version: 1.720
Distribution: unstable
Urgency: high
Maintainer: Debian Edu Developers <debian-edu@lists.debian.org>
Changed-By: Petter Reinholdtsen <pere@debian.org>
Description: 
 debian-edu-config - Configuration files for Skolelinux systems
 debian-edu-config-gosa-netgroups - netgroups plugin for GOsa²
Closes: 669762
Changes: 
 debian-edu-config (1.720) unstable; urgency=high
 .
   * Upload with urgency high to fix hanging Main Server installation.
 .
   [ Petter Reinholdtsen ]
   * Updated Norwegian Bokmål debconf translation.  Translated by Petter
     Reinholdtsen.
   * Add Alexander Alemayhu as uploader.
   * Adjust the ldap-debian-edu-install script to stop named also when
     failing to get a Samba SID.  This avoid hanging the installer when
     unable to set up LDAP and Kerberos for the the Main Server.
   * Migrate setup to Apache 2.4 (Closes: #669762).  Rename conffiles
     /etc/apache2/conf.d/debian-edu-config-doc,
     /etc/apache2/sites-available/debian-edu-default and
     /etc/apache2/sites-available/debian-edu-ssl-default to
     /etc/apache2/conf-available/debian-edu-config-doc.conf,
     /etc/apache2/sites-available/debian-edu-default.conf and
     /etc/apache2/sites-available/debian-edu-ssl-default.conf.  Update
     Apache 2 cfengine rules to enable configuration on fresh installs.
   * Update from debhelper version 7 to 9 to get the support needed for
     the Apache 2.4 migration.
   * Extend nagios test to detect if nagsio3 is completely missing.
   * Adjust ldap-debian-edu-install to log the error when failing to get
     the samba sid.
 .
   [ Alexander Alemayhu ]
   * debian/control:
     - Update the Vcs-* fields for the git migration.
 .
   [ Wolfgang Schweer ]
   * Update setup instructions in ldap-debian-edu-install to enable password
     storage in secrets.tdb (new location: /var/lib/samba/private/).
   * Fix path to secrets.tdb in ldap-debian-edu-install.
   * Make failing SAMBASID fetch non-fatal in ldap-debian-edu-install.
   * Adjust testsuite/cups; the daemon is now called cups-browsed.
 .
   [ Petter Reinholdtsen ]
   * Set samba sid to 'bogus-sid' when continuing the ldap-debian-edu-install
     script.
   * Extend testsuite/webcache to detect if the squid binary is missing.
Checksums-Sha1: 
 54dee2abcb126da14149da7be3590e95ab4fd5d5 1338 debian-edu-config_1.720.dsc
 a396f411645fc2f2140b32b94fc2d4d9bdfce954 532703 debian-edu-config_1.720.tar.gz
 e9f8a9f6af222456192aee106a9b56b57c0a3864 418570 debian-edu-config_1.720_all.deb
 06cac9e371da35633c4253be8780099ac8c55331 125046 debian-edu-config-gosa-netgroups_1.720_all.deb
Checksums-Sha256: 
 ae3c4402a55fce18bd0cee1975c2e2e915d88d7ff6d4e44ed4f978199d6be35e 1338 debian-edu-config_1.720.dsc
 7c2f192e2b85004d8b949c4dbdce7ef7861be102406b7914f8fc5858400d7e80 532703 debian-edu-config_1.720.tar.gz
 1a490ed882483fe6a647e9f47e5e543ad55acba1d21f34e34bb19da026c692b6 418570 debian-edu-config_1.720_all.deb
 3eefea5ad37b1864ad1e9df7887eaa153d838a9e0810a0a915ef0c2140afdb65 125046 debian-edu-config-gosa-netgroups_1.720_all.deb
Files: 
 fb336a230e0482bb8ee4d3c9de942357 1338 misc extra debian-edu-config_1.720.dsc
 428c333ed86cc4d8029b07d95f32a73c 532703 misc extra debian-edu-config_1.720.tar.gz
 a6dd9aaa3e7b28dae93859e49f07f742 418570 misc extra debian-edu-config_1.720_all.deb
 1f064ff6b5b6a930896748d0d41d8f14 125046 misc extra debian-edu-config-gosa-netgroups_1.720_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iD8DBQFT93Ho20zMSyow1ykRAor0AJ9Gjt7Eqry+qkVGlnYvdizU5Sr4AwCfaOy8
ADHXNTkHL08jM4XVtljw6oU=
=EwWu
-----END PGP SIGNATURE-----

--- End Message ---

Reply to: