[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error adding users in Gosa (wheezy-test 130817)

[Arne Sørli]
> When trying to add users using Gosa in current wheezy-test, I get
> the following errors:
>   Cannot find group SID in your configuration!
>   Cannot find any SID for 'DEFAULT'!
>   Cannot find any RIDBASE for 'DEFAULT'!
> Tested on fresh install of
> cd-wheezy-test-usbstick/debian-edu-amd64-i386-BD-1.iso, timestamp
> 2013-08-17 16:30.

I see this too, and believe it is in what we planned to release as
beta1 today.  I put the beta1 plans on hold until we figure out this

Looking at the changes done since svn revision 81928, I've tried to
undo the changes to ldap-tools/ldap-debian-edu-install, without
anything changing.  Now I am trying to undo the first two changes done
etc/samba/smb-debian-edu.conf, to see if that could be the cause.

This was the first patch I tried to revert (manually by editing the
files during installation):

Index: ldap-tools/ldap-debian-edu-install
--- ldap-tools/ldap-debian-edu-install  (revision 81928)
+++ ldap-tools/ldap-debian-edu-install  (working copy)
@@ -429,11 +429,11 @@
    security = USER
    workgroup = SKOLELINUX
    encrypt passwords = true
-   passdb backend = ldapsam:"ldap://ldap.intern";
+   passdb backend = ldapsam:"ldapi:///"
    ldapsam:trusted = yes
    ldap suffix = ou=samba,dc=skole,dc=skolelinux,dc=no
    ldap admin dn = "cn=admin,ou=ldap-access,dc=skole,dc=skolelinux,dc=no"
-   ldap ssl = start_tls
+   ldap ssl = no
    local master = yes
    domain logons = yes
    domain master = yes

This is the patch I try to revert now (installation still going):

Index: etc/samba/smb-debian-edu.conf
--- etc/samba/smb-debian-edu.conf       (revision 81928)
+++ etc/samba/smb-debian-edu.conf       (working copy)
@@ -38,12 +38,10 @@
    security = USER
 # security setting
-   null passwords = no
    map to guest = Bad User
    guest ok = No
 # server/client spnego
-   use spnego = yes
    client use spnego = yes
 # Workgroup/NT-domain name

I do not know samba much, so I am mostly trying to undo random changes
to see if I could locate the problem.

Happy hacking
Petter Reinholdtsen

Reply to: