[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: tzdata problems etc

Hi Petter,

On Mon, Jul 08, 2013 at 06:22:59PM +0200, Petter Reinholdtsen wrote:
> [Giorgio Pioda]
> > Hi,
> Hi.  Very glad to see your test report.  I'm collecting the lot in one
> email to address your questions together, as some of them are related.
> > after a fresh install with daily wheezy-test image NETINST iso...
> Which installation choices did you select?

I used the NETINST iso image burned on a CD.

> > The first login went ok, but after changing subnet the login
> > was no more possible with the first user.
> This was strange, and did not happen when I tested this.
> > Kerberos was ok, kdm complained about K time zone.
> > 
> > I fixed it running dpkg-reconfigure tzdata as root.
> What was the exact message from kdm?  Was this on the main-server
> after you booted after running the subnet-change script?

Long output in kdm.log mainly a:

kdmgreet (4141)/kdecore (K*TimeZone*) complaining that ktimezoned D-Buss call failed

> > I guess I have to add all the devices that are using fixed
> > IP as netdevices to make an IP reservation (for
> > example printers)
> > 
> > Isn't it?
> Yes, or add them as printer objects.  Either way should work fine.
> > after a tjener install (daily NETINST iso amd64) and subnet change
> > to /23 I modified the PXE boot to get automated gnome install on
> > i386 profile.
> > 
> > No idea if related to these modifications or not, but the squid
> > is not populating during PXE install.
> This seem like a bug, the same you discovered here:
> > looking for the non populating squid, I noticed that in
> > debian-edu-install.dat the lines
> > 
> > d-i      mirror/http/proxy  string
> > d-i       mirror/ftp/proxy   string
> > 
> > are not showing the proxy address, just the string string.
> > 
> > Is it correct?
> It should list http://webcache:3128 as the proxy, and the setting is
> done by debian-edu-pxeinstall.  This do not happen when I test it, but
> I have seen it some times.  Can you tell us more about how you
> installed the main-server in question?  What was the network
> environment during installation and first boot?

I fixed it manually putting the correct IP, now squid gets populated

> What is the output from 
> "grep error: /var/log/installer/debian-edu-install-testsuite" on the
> machine in question?

Not that bad:

-error: ./doc: RElease manual have 9 FIXME....
-error: ./nagios: Nagios count NUMSVCCRIT is not zero but 1 (two lines)
-error: ./webcache: WPAD file 'http://wpad/wpad.dat' is missing HTTP proxy info.

Thus a script is not generating correctly a http proxy variable, and this is
found in two places in the configs. What about nagios?



Giorgio Pioda - Sysadmin SPSE-Tenero
Cell +41 79 629 20 63
Uff. +41 91 735 62 48

Reply to: