[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#574710: education-common: Should not install and enable libpam-ssh by default

Package:  education-common
Version:  0.844
Severity: grave
Tags:     patch
User:     debian-edu@lists.debian.org
Usertag:  debian-edu

As reported in bug #574708, I believe libpam-ssh causes problems with
cron.  And given the fact that Debian Edu never have enabled this
module and do not really need it, I believe we should reduce its
depend on ignore (or perhaps even drop it?) in the common task to
avoid the problem.

The problem only show up in squeeze/testing, because pam configuration
is not set up automatically based on information provided by the
libpam* packages.  This enable libpam-ssh and exposes us to its

This patch reduces it from depends to ignore.

Index: tasks/common
--- tasks/common        (revision 63138)
+++ tasks/common        (working copy)
@@ -25,7 +25,8 @@
 Responsible: Petter Reinholdtsen
 NeedConfig:  no

-Depends:     openssh-client, libpam-ssh
+Depends:     openssh-client
+Ignore:      libpam-ssh
 Avoid:       ssh-askpass
 Why:         Allow connections to remote hosts.
 Responsible: Petter Reinholdtsen

Happy hacking,
Petter Reinholdtsen

Reply to: