[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Pushing kde4 into testing

Hash: RIPEMD160

On Tue, May 12, 2009 at 10:53:37PM -0700, Vagrant Cascadian wrote:
>On Tue, May 12, 2009 at 03:45:38PM -0700, Vagrant Cascadian wrote:
>> On Tue, May 12, 2009 at 12:29:14PM +0200, Adeodato Simó wrote:
>> > > |libqt-perl (= 3.008-4): FAILED
>> > > |The following constraints cannot be satisfied:
>> > > |  libqt-perl (= 3.008-4) depends on libsmokeqt1 (>= 4:3.5.10) {NOT AVAILABLE}
>> > 
>> > > Won't be fixed until after the summer, remove for now. Maintainer 
>> > > aware.
>> > 
>> > Well, the problem is that libqt-perl has reverse dependencies. In 
>> > particular, debian-edu-install. We need a solution for that...
>> would it be possible to lower the dependency to a recommend on 
>> libqt-perl, as it should still get installed by default if available 
>> (i.e. the lenny-based debian-edu), but allow kde4 to progress into 
>> squeeze...

Recommends are recommended at a the package level, but required at the 
distro level.  Or so I believe (although I failed to locate it in Debian 

>> alternately, even though debian-edu focuses on KDE, what about 
>> putting in a "libqt-perl | libgnome2-perl" dependency, and fall back 
>> to the GNOME frontend if libqt-perl is not available?

I believe that the _first_ item in a list of multiple recommendations 
must be satisfiable.

In other words, I suspect above approach might not work for getting the 
package into testing and stable, even though it works with apt-get and 

>i committed a third alternative to svn: changed the dependency to 
>"libqt-perl | xdialog" and set DEBCONF_FORCE_XDIALOG=true. this should 
>still default to the kde debconf frontend, but if that isn't available, 
>it should then fall back to using the dialog frontend with Xdialog 
>(which has fewer dependencies than libgnome2-perl)... though i haven't 
>tested it yet. :)

Perhaps also add support for libwx-perl-dialog-perl and/or use 

  - Jonas

- -- 
* Jonas Smedegaard - idealist og Internet-arkitekt
* Tlf.: +45 40843136  Website: http://dr.jones.dk/

  [x] quote me freely  [ ] ask before reusing  [ ] keep private
Version: GnuPG v1.4.9 (GNU/Linux)


Reply to: