[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Bug 1268] New: LWAT error while adding a user - Lwat is confused because of samba


           Summary: LWAT error while adding a user - Lwat is confused
                    because of samba
           Product: Skolelinux
           Version: woody-release-1.0r1
          Platform: x86
               URL: https://www/lwat/
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: lwat
        AssignedTo: debian-edu@lists.debian.org
        ReportedBy: jpduyx@yahoo.com

i try to add a user to lwat


username test user
login:  tesuser

user template: Students

i get as a result: 

I'm confused. There is not one sambaDomain and one only in ldap

Warning: ldap_add() [function.ldap-add]: Add: Invalid syntax in
/usr/share/lwat/web/functions.php on line 625

    [dn] => uid=tesuse,ou=People,dc=skole,dc=skolelinux,dc=no
    [uidNumber] => 10033
    [gidNumber] => 10033
    [uid] => tesuse
    [cn] => test user
    [userPassword] => {SSHA}Z6VmDbsFyU0zP6Be2QXzNKW9zEs1NzMy
    [objectClass] => Array
            [0] => top
            [1] => posixAccount
            [2] => shadowAccount
            [3] => imapUser
            [4] => sambaSamAccount

    [homeDirectory] => /skole/tjener/home0/tesuse
    [loginShell] => /bin/bash
    [mailMessageStore] => /var/lib/maildirs/tesuse
    [sambaSID] => 
    [sambaAcctFlags] => [U          ]
    [sambaLMPassword] => 4A895D40A1AE8CE6C81667E9D738C5D9
    [sambaNTPassword] => FABBEDAE2CF36F56B26B3D146E31B991

Enter full name of the user:
Select user template: 	Username:

Import from file
Added user: test user
username: tesuse
password: gUoCeJ26

eventough   a password is generated and it says that the added user is test
user, no user is added to the system

its impossible to add any user of any group, or with any kind of name, i tried a
lot, my quess is that it has to do with the fact that lwat is confused about
samba, but how can i make lwat unconfused ? 

I have not setup any samba domain in skole linux
on my other system (in the same network) i do have a samba share. i tried
shutting down that machine with samba, but it seemed like i kept getting the
same error messages. and no user was added.

with kind regards

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

Reply to: