[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Could skolelinux etch test pr00 be released?

Hello Knut, Hello Fabian,

as you see, I have sent my notes yesterday.

Today I checked debian-edu, but did not find my answer to your request.
Is the list regulated and my mail not accepted, or is ther a technical
problem with my headers or my e-mail-system?

Am Montag, den 17.07.2006, 10:12 +0200 schrieb Dr. Uwe Doebereiner:
> >===== Original Message From Knut Yrvin <knuty@skolelinux.no> =====
> >
> >So Uwe, is it possible for you to share your German notes on the
> >developer list (this list), so that it's more easy for people to start
> >testing.
> >

> Hello,
> find my/our log as an attachment. Take it, as it is. I edited and tried to 
> make it readable in English too.
for the experts it is too long, but I tried my best to get it complete.

Skolelinux Developer Camp Carreau Wendel 8.-15.07.2006
Testing of the currant etch CD-image of an debian-edu-i386-binary-1.raw

What we wanted to do and did

Install a virtual  SkoleLinux-Server and -Workstation (as -Client) on a 
 Computer within qemu and test the virtual network connection.

Advice and Programming: Fabian Franz, FabianFranz@GMX-de
Hardware transport and watching the installation: Uwe Doebereiner,udoebus@kud.com

that is the binary-image we used:
-rw-r--r--  1 udoebus udoebus 651925504 2006-07-13 12:09 debian-edu-i386-binary-1.raw

What I, Uwe, had to learn: 
working with qemu needs switching between 3 screen layers:
1. X-Server with the mouse

2. in the qemu-command line: prepare switching back and forth with  
        sendkey <ctr><alt><f1>  <return>
        sendkey <ctr><alt><f7>  <return>

3. virtual program screen leave it to the X-screen with <ctr><alt> 
   leave it to the qemu-command-line with <ctrl><alt>2
   back to it with  <ctrl><alt>1

go into it with mouse<left>

We did the downloading to my Laptop ``doberan8'' and copied the files to ``doberan7''.

My computer used for the testing, named doberan7:
AMD Winchester, Athlon(tm) 64 Processor 3000+, 1800 MHz
board GIGABYTE K8Triton GA-K8NSC-393,
memory 2 GByte (Corsair 4 modules à 512MB; VS1GBKIT400))
Graphics ATI PowerColor 9250;  ethernet e100-IDE- card 
(the on-board ethernet Marvell-Chip not functioning  
(tried drivers sk98lin.ko and skge.ko)
gpm-mouse had to be stopped to use the mouse within the X-screen properly.

 Kernel installed on my computer 
 Linux version 2.6.6-1-k7 (herbert@gondolin) (gcc version 3.3.3 (Debian 20040401)) #1 Wed May 12 18:19:40 EST 2004

2 IDE-Harddisks à 160 GByte,
 configuered  as  0.5-BIOS-RAID, yielding 160 GByte available

Installed GNU-DEBIAN Sarge-3.1, just updated  from ftp.de.debian.org 

Screencopies of the commands given:

to make loopdevice
 dd if=/dev/zero of=festplatte.img bs=5G count=4 # (for SkoleLinux-Server)
dd if=/dev/zero of=festplatte2.img bs=1G count=4 #(for SkoleLinux-Workstation-Client)

Start of the installation as from a cdrom, calling the image as downloaded

qemu -cdrom debian-edu-i386-binary-1.raw -hda festplatte.img -boot d
(to restart quemu festplatte.img only, "-boot d" would start from -cdrom) 

Description of the installation run (observations, questions, answers)

Anmerkung: Das derzeitige Image startet zunächst nicht mit dem 2.6 Kernel, sondern  nur mit dem  2.4 Kernel:
Comment: The current image used does not start with the default 2.6 Kernel, but with the 2.4 Kernel.

Folgender Fehler tritt auf: Es erscheint die rote Skolelinux-Eingabescreen;
Error: the red SkoleLinux pops up

 beantworten mit: install24
answer the prompt: install24

Debian-Installer Questions: 
Zu installierende Oberfläche beantwortet mit: Server und Client
                            (*) Server, (*)Client

(nicht angewählte Alternativen waren Workstation und Standard).

Question: erase entire disk; beantwortn mit ja
Hint: security updates are commented out in sources.list.

Hinweis: Für den hier verwendeten Download melden Nutzer  Probleme bei der Installation des X-servers. Das xserver-xorg package sollte in diesem Fall nachinstalliert werden.
Comment: users said, xserver-xorg does not start, has to be reinstalled afterwards

finish installation as usual. give root password. Later on,  you will wish, you had added a first user.
Nach Installationende reboot mit  Fehlermeldung:
reboot command, ending with error

Neueingabe:  qemu -hda festplatte.img
restart with qemu -hda festplatte.img

Startet mit Kommondozeilen login:
start into login:

prompt ~/ homeverzeichnis root leer. Graphisches Skolelinux-Login hier nicht verfügbar (war ja Fehlermeldung des hier verwendeten Abzugs.)

qemu -hda festplatte.img

Was macht jetzt der Unerfahrene (Tester/Lehrer). Empfehlenswert README.txt mit Anweisungen. Zumindest für mich und etch als Testing-Version?

Bei Aufruf von dselect funktioniert nicht der / (slash), allerdings andere Buchstaben und die Pfeiltasten: Erklärung wäre gewesen, das keyboard-layout ist  English

/ für den Aufruf der Suchfunktion steht nicht zur Verfügung. No German /, English keyboard is installed!
Tastatureingabe < shift-q  > erfolgreich. Deselect kann verlassen werden.

Alle xserver-xorg Packages sind selected. 

Wie erfolgt die Neuinstalltion des X-servers? , 

reboot startet System neu
halt funktioniert. Nach Schließen des qemu-Fensters wieder im X-Fenster, aus dem der Aufruf erfolgte.

Nach Installation eines neuen Kernels im virtuellen PC durch Fabian wurde der X-server gestartet. Allerdings konnte da root nicht einloggen, 
mußte mit dem für das Umschalten angelegten <ctrl><alt><2> in das root 

Screenshot of the commands given:

udoebus@doberan7:~$ qemu -cdrom de <TAB>
debian-edu-i386-binary-1.raw   definitive_guide_to_plone.pdf
udoebus@doberan7:~$ qemu -cdrom debian-edu-i386-binary-1.raw -hda festplatte.img -boot d

udoebus@doberan7:~$ qemu -hda festplatte.img
[1]+  Stopped                 qemu -hda festplatte.img

udoebus@doberan7:~$ fg
qemu -hda festplatte.img
udoebus@doberan7:~$ qemu --help

How it worked and should work now
#Downloak des raw images von ........ als debian-edu-i386-binary-1.raw 

Festplattenimage erstellen:

dd if=/dev/zero of=festplatte.img bs=5G count=4

udoebus@doberan7:~$ qemu -cdrom debian-edu-i386-binary-1.raw -hda festplatte.img  -boot d
udoebus@doberan7:~$ qemu -hda festplatte.img 

Anlegen des 2. möglichen qemu für den SkoleLinux Client
make a 2. virtual partition for the SkoleLinux-Client/-Workstation

dd if=/dev/zero of=festplatte2.img bs=1G count=4
udoebus@doberan7:~$ qemu -cdrom debian-edu-i386-binary-1.raw -hda festplatte2.img  -boot d

Installation of the  debian-edu-i386-binary-1.raw starts with an error-message, because it can't start with
a 2.6 Kernel still

answer the error prompt with install 24

The system used will not  install the Xorg-server correctly

after failure to reboot, you have to leave the install screen with ctrl-alt and close it with the mousepointer in the top-left X :-)

restart with  qemu -cdrom debian-edu-i386-binary-1.raw -hda festplatte2.img
login as root with the password you set in the first install run

now we want to install a new 2.6 kernel within the freshly installed SkoleLinux-System

#: . /etc/bash_completion (we want to search for the new client on the cdrom-raw-file  (to start completion with <TAB>
#: apt-get install kernel-image-2.6.... seach with <TAB>s <return>

error: cdrom not found. You have to switch to the qemu command line  to insert the "cdrom-image" into  cdrom-Drive on the qemu-level
so change to the qemu-screen one level out of the present screen level with 
change cdrom ../debian-edu-i386-binary-1.raw (tabbing)

back to the installation-screen
repeat #: one back in the history ( ^-Cursor) and <RETURN>
the new 2.6-Kernel should install now

the new kernel will install.
now <adduser testuser> to ad a user, who is allowd to login into the KDE-login (root will not!)

 Reboot now goes into the qemu-screen, showing the grub boot-promt

In our Example-Installtion we now got the X-Server SkoleLinux Input-Login-Screen
you can't login as root

so login into the Menu-Button, select Terminal
login as root, then <adduser testuser>
logout will deliver the KDE-Login again.

After a halt, qemu was started again, to incorporate the acceleration with k-kernel-mode _and_ to have an additional network 
stop the emulation.
start ist again with

udoebus@doberan7:~/fabian$ qemu -kernel-kqemu -cdrom ../debian-edu-i386-binary-1.raw -hda festplatte2.img -net nic,macaddr=52:54:00:12:34:58 -net socket,connect=:1234

udoebus@doberan7:~$ qemu -hda festplatte2.img 
udoebus@doberan7:~/fabian$ qemu -kernel-kqemu -cdrom ../debian-edu-i386-binary-1.raw -hda festplatte2.img

qemu -h to get help
udoebus@doberan7:~$ qemu -cdrom debian-edu-i386-binary-1.raw -hda festplatte.img  -boot d
udoebus@doberan7:~$ qemu -cdrom debian-edu-i386-binary-1.raw -hda festplatte.img  -boot d

Einrichtung Netzwerke im qemu
Configure internal networking

für den tjener.intern in einem X-Terminal
for tjener.intern start in an X-terminal

udoebus@doberan7:~$ qemu -kernel-kqemu -hda festplatte.img -net nic,macaddr=52:54:00:12:34:56 -net socket,listen=:1234 -net nic,macaddr=52:54:00:12:34:57 -net socket,listen=:1235

in einem anderen/neuen X- Terminal für den client1.intern:
in another/new X-terminal for an client1.intern

udoebus@doberan7:~/fabian$ qemu -kernel-kqemu -cdrom ../debian-edu-i386-binary-1.raw -hda festplatte2.img -net nic,macaddr=52:54:00:12:34:58 -net socket,connect=:1234

Für server mit nur Internet:
server with connection to the external Internet:

udoebus@doberan7:~$ qemu -hda festplatte.img -net nic,macaddr=52:54:00:12:34:56 -net user -net nic,macaddr=52:54:00:12:34:57

dann dhclient eth0
und resolv.conf edititeren.

remember to configure screen switching with in the qemu commandline
# Verlassen der qemu-Shell zum übergeordenten X-server mit ctr-alt
# Innerhalb des qemu Umschalten auf anderes Terminal mit 

sendkey <ctr><alt><f1>
sendkey <ctr><alt><f7>

umschalten ctrl+alt+1 virtueller server oder client
umschalten ctrl+alt+2 qemu ebene


>From Klaus Knopper We got a version of a current 

udoebus@doberan7:~/fabian$ dd if=/dev/cd <TABbing>
###Kopie Knoppix cd

cdrom   cdrom0  cdu535
udoebus@doberan7:~/fabian$ dd if=/dev/cdrom of=Knoppix_5.0.1-DVD.iso
dd: öffne ,,/dev/cdrom": Keine Berechtigung
udoebus@doberan7:~/fabian$ su -c "dd if=/dev/cdrom of=Knoppix_5.0.1-DVD.iso"
dd: öffne ,,/dev/cdrom": Kein Medium gefunden
udoebus@doberan7:~/fabian$ su -c "dd if=/dev/dvd of=Knoppix_5.0.1-DVD.iso"
dd: öffne ,,/dev/dvd": Datei oder Verzeichnis nicht gefunden
udoebus@doberan7:~/fabian$ su -c "dd if=/dev/cdrom0 of=Knoppix_5.0.1-DVD.iso"
dd: öffne ,,/dev/cdrom0": Kein Medium gefunden
udoebus@doberan7:~/fabian$ mount
/dev/hda1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/hda5 on /home type ext3 (rw)
usbfs on /proc/bus/usb type usbfs (rw)
udoebus@doberan7:~/fabian$ mount /cdrom

(my configuration of doberan7 is waiting for a perfect Admin :-) ) 

Don't forget to install the acceleration -kernel-kqemu!

Uwe, guided by Fabian

Reply to: