[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Misc issues/problems with installation of latest debian-edu sarge cd

I'll go straight to the point:

1. .X11-unix and .ICE-unix take too long to initialize at boot time, I 
don't know why, there doesn't seem to be much disk activity any 

2. Well, this was actually fixed with the help from Finn-Arne, but I 
thought i'd mention the fix, in case someone else has the same setup. 
Basically, the school doesn't use to connect to the 
Internet, and there is no router as all schools in Greece are 
connected to a central school network which uses the 10.x.x.x 
netgroup. So I had to follow the dummy ethernet device trick.
But, as the DHCP server from the school network also adds entries to 
the resolv.conf, following Finn-Arne's advice, I had to:

a) install resolvconf package
b) add the following entries to /etc/network/interfaces:
    auto dummy0
    iface dummy0 inet static
        dns-search intern

That fixed everything.

3. All LTSP clients used serial mice, so I had to edit the LTSP 
configuration file /opt/ltsp/i386/etc/lts.conf (which doesn't exist 
by default, maybe we should add a template file and just comment 
everything out for the user to fill?) and add the following lines:

    USE_XFS = Y
    X_MOUSE_PROTOCOL = "Microsoft"
    X_MOUSE_DEVICE   = "/dev/ttyS0"

4. Screen resolution for the LTSP clients. I couldn't find any info on 
that in any configuration file I searched. I tried adding the 
following line to /opt/ltsp/i386/etc/lts.conf but it didn't work:
    X_MODE_0        = 1024x768

Any ideas?

5. frequent NFS stalls. This is probably the most serious problem. On 
the same 100Mbps network of 12 lowend LTSP clients on a switch and a 
beefy server, previous installation of Skolelinux (old generation of 
LTSP packages) was quite fast in booting and loading applications. 
Now, I get quite frequent messages:
NFS server does not respond, still trying (or similar, I 
am not in the lab right now).
One of the teachers informed me that after 2 hours of waiting only 3 
of the 12 LTSP clients booted and he had to reboot them one by one 
manually afterwards.
I cannot explain why this is happening, Finn-Arne suggested that the 
new LTSP packages consume much more network resources than previous 
versions, but it seems too much of a slowdown -if it can be called 
that- for me. I tried checking for lost interrupts 
in /proc/interrupts, just in case there is a buggy ethernet driver in 
the kernel, but to no avail. Any ideas that I could check?

On the same issue of NFS, I also noticed that all NFS mounts are done 
without setting rsize/wsize to 8192. AFAIK, using these settings is 
recommended for better performance, is there a reason they are not 
set? I did try to set them but I failed to find the configuration 
file to set them up (I thought they'd be in /opt/ltsp/i386/etc/fstab 
but they were not :-/). Any ideas on this also?

6. Xkb Keymap switching on the LTSP clients.
It just works fine now right out of the box, thanks to the NG LTSP 
packages which don't include the problematic XF86 3.x, which means I 
can and will suggest Skolelinux to be installed to the Greek schools, 
I waited for this moment a long time and I'm so happy, I'll let you 
know about this! :-)

7. Translation for ldm. It doesn't appear to be translatable, at least 
I couldn't find a .pot file for it. Is it planned to be translated?

Thanks for any help.


Attachment: pgphItXs73rYW.pgp
Description: PGP signature

Reply to: