[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#680626: Squeeze->Wheezy: dist-upgrade fails, /usr/bin/python unable to load libssl.so.1.0.0

On Sun, 2012-07-15 at 17:14:26 +0200, Julien Cristau wrote:
> On Sat, Jul  7, 2012 at 14:51:32 +0200, bertagaz wrote:
> > In an attempt to test upgrading Squeeze to Wheezy now that the Big Wheezy
> > Freeze has come, it failed at the dist-upgrade step.
> > 
> > I installed a fresh Debian Squeeze and tested from it.
> > 
> > I wanted first to see if it would be possible to upgrade with a simple and
> > graphical method (using update-manager and synaptic), as it was quite
> > complicated for the Lenny->Squeeze upgrade.
> > 
> > Ended up with this result, so I also tested using plain apt-get upgrade
> > and dist-upgrade.
> > 
> > Same result, dist-upgrade fails on python-support postintallation script
> > with the following error:
> > 
> > Processing triggers for python-support ...
> > /usr/bin/python: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
> > dpkg: error processing python-support (--unpack):  subprocess installed post-installation script returned error exit status 127

> Looks like dpkg is running triggers from packages that aren't
> configured.  Can dpkg folks have a look at this?  Bug#680626 has the
> details.

W/o having looked yet at the details I'd say this *seems* like #671711,
which I'm not planning on fixing for wheezy as it would introduce
regressions on other situations, and given that this behaviour has
been around since the introduction of triggers, and while quite
unfortunate it's something that will have to be worked around on the
affected packages because older dpkg will not be able to handle this
correctly anyway.

Going to look now, to make sure the above is the case.


Reply to: