[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Proposal for a "Bits from dpkg developers"

Guillem Jover wrote:

> Ok! Release tagged, pushed and uploaded.
> I reworded some things, and added the new stuff since 1.15.7 that I
> mentioned on my other mail. Hope to not have missed anything else
> important/user visible. Please take a look, and feel free to send.

Re the new triggers:

|  If the trigger processing is not critical for the activating package
|  to actually work, then you should consider using these new
|  directives. If you do so, you will have to add a
|  “Pre-Depends: dpkg (>= 1.16.1)” to ensure the new dpkg is
|  installed even before your package is unpacked. See deb-triggers(5)
|  for details.

Has it been discussed on debian-devel whether such a Pre-Depends
is worth it, and if so for which packages?

I personally think that it really would be worth it in this case for
any package of priority "standard" or lower (and maybe even packages
of priority "important"), but if we're making this announcement
without having had that discussion, then the email should say
something like "Before doing so, please consult debian-devel so the
impact on upgrades can be considered".


Reply to: