Re: Some upcoming dpkg changes, test and feedback welcome
On Fri, 2011-07-29 at 16:31:36 +0200, Raphael Hertzog wrote:
> On Wed, 20 Jul 2011, Raphael Hertzog wrote:
> > Thus my personal preference would be to provide something to cover
> > those use cases.
> I attached a patch for this. I ended up diverging slightly on the
> variable names to be more consistent.
Given that my remarks probably apply to most of the other make snippets
and variables, you went ahead anyway, and I cannot be bothered to argue
against this, I'll at least comment on the naming/implementation:
> +# DEB_SOURCE_PACKAGE: the source package name
Why DEB_SOURCE_PACKAGE instead of say, DEB_SOURCE? I guess it depends if
we want to map to field names or to more descriptive (although probably
redundant) variable names.
> +# DEB_VERSION: the full version of the package
> +# DEB_VERSION_NOREV: the package's version without the Debian revision
> +# DEB_VERSION_NOEPOCH: the package's version without the Debian epoch
> +# DEB_VERSION_UPSTREAM: the package's upstream version
These do not seem to have ended up being completely consistent,
there's a mix of variables listing what's missing, and variables
listing what's included. What about something like:
> +# DEB_DISTRIBUTION: the first distribution of the current entry in debian/changelog
Why only the first, what makes it special? If there's multiple filter
can always be used.