[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFH: #537950 ia32-apt-get: libkrb53 installtion problem

Raphael Hertzog <hertzog@debian.org> writes:

> On Tue, 28 Jul 2009, Goswin von Brederlow wrote:
>> Package: ia32-libgssapi-krb5-2
>> Architecture: amd64
>> Version: 1.7dfsg~beta3-1~22
>> Replaces: ia32-libkrb53 (<< 1.6.dfsg.4~beta1-7~22), ia32-libs, ia32-libs-gtk
> Replaces is versionned.
>> dpkg: error processing
>> /var/cache/ia32-apt/archives/ia32-libkrb53_1.6.dfsg.4~beta1-5lenny1~22_amd64.deb (--unpack):
>>  trying to overwrite `/usr/lib32/libgssapi_krb5.so.2.2', which is also in package ia32-libgssapi-krb5-2
>> Errors were encountered while processing:
>>  /var/cache/ia32-apt/archives/ia32-libkrb53_1.6.dfsg.4~beta1-5lenny1~22_amd64.deb
>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>> Afaik the right thing to prevent this is a Replaces entry but that is
>> already there. So what is going on?
> The Replaces is not on the right package given the message. ia32-libkrb53
> should replace ia32-libgssapi-krb5-2 and not the opposite. Also
> 1.6.dfsg.4~beta1-5lenny1~22 is excluded from the Replaces currently given
> it's << and not <=. So even if the replace indicated applied before-hand, it
> doesn't apply anymore to this release.

The ia32-libkrb53 package is the stable one, ia32-libgssapi-krb5-2 is
testing/unstable. The user is installing the replaced packages after
the replacing package. But dpkg should handle that.

% dpkg --compare-versions "1.6.dfsg.4~beta1-5lenny1~22" "<<" "1.6.dfsg.4~beta1-7~22" && echo yes

The version dpkg tries to unpack is smaller than the one in the

> Cheers,
> -- 
> Raphaël Hertzog


Reply to: