[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RFH: #537950 ia32-apt-get: libkrb53 installtion problem


something strange is going on with this bug that I can't make sense
of. Dpkg complains about an overwrite conflict despite a correct
Replaces field:

Package: ia32-libgssapi-krb5-2
Architecture: amd64
Version: 1.7dfsg~beta3-1~22
Replaces: ia32-libkrb53 (<< 1.6.dfsg.4~beta1-7~22), ia32-libs, ia32-libs-gtk

But when ia32-libkrb53_1.6.dfsg.4~beta1-5lenny1~22_amd64.deb is
unpacked dpkg complains:

Unpacking ia32-libkrb53 (from
..../ia32-libkrb53_1.6.dfsg.4~beta1-5lenny1~22_amd64.deb) ...
dch warning: new version (1.6.dfsg.4~beta1-5lenny1~22) is less than
the current version number (1.6.dfsg.4~beta1-5lenny1).
dpkg: error processing
/var/cache/ia32-apt/archives/ia32-libkrb53_1.6.dfsg.4~beta1-5lenny1~22_amd64.deb (--unpack):
 trying to overwrite `/usr/lib32/libgssapi_krb5.so.2.2', which is also in package ia32-libgssapi-krb5-2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Afaik the right thing to prevent this is a Replaces entry but that is
already there. So what is going on?

Note that the users ia32-apt-get is from unstable, libgssapi-krb5-2 is
from testing/unstable and libkrb53 is from stable. So there is a bit
of a mix of releases. Would it matter if dpkg is from stable?


Reply to: