[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Transition from dpkg to GNU install-info

On Thu, 12 Mar 2009, Norbert Preining wrote:
> - install-info is installed in /usr/sbin and the package carries a
>   Replaces: dpkg (<= 1.14.25) which is current unstable version

The Replaces has to be unversioned if dpkg continue to ship
a no-op /usr/sbin/install-info (which is the plan seen on the wiki AFAIK).
(BTW 1.15.0 exists in experimental)

However I don't find this very nice. 

I would rather have the new install-info in /usr/bin/, and dpkg
ships an /usr/sbin/install-info that does nothing but calls
/usr/bin/install-info if it exists and warn otherwise. (And also warn if
it's called with the full path).

And in lenny+1 we can remove /usr/sbin/install-info.

We avoid the need for the replace and we have a nice transition.

dpkg should maybe add a versioned Breaks: on the most popular info
browsers to force their upgrade to a version that Depends on install-info.

How does that sound ?

Raphaël Hertzog

Contribuez à Debian et gagnez un cahier de l'admin Debian Lenny :

Reply to: