[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#256302: XSI:isms in several scripts

On Sat, Jun 26, 2004 at 03:28:09PM +0100, Scott James Remnant wrote:
> On Sat, 2004-06-26 at 01:37 +0200, David Weinehall wrote:
> > Several scripts in dpkg contains use of the XSI:isms `-a' and `-o' for
> > `test'/`['.  This is technically a policy-violation.
> > 
> They seem to be allowed under POSIX and inherited from XSI, unless I'm
> misreading the URL you provided.
> > http://www.opengroup.org/onlinepubs/009695399/utilities/test.html

No, XSI is an extension, not a part of POSIX; not all POSIX systems
are compliant with the XSI.  Also, -a and -o contains
portability problems, read subsection "Application Usage" for
more information.

Regards: David Weinehall
 /) David Weinehall <tao@acc.umu.se> /) Northern lights wander      (\
//  Maintainer of the v2.0 kernel   //  Dance across the winter sky //
\)  http://www.acc.umu.se/~tao/    (/   Full colour fire           (/

Reply to: