[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: something incredibly amiss in unstable and dpkg

My problem was that /var/lib/dpkg/available had been
corrupted.  Not sure how.  You can see one aspect of the
problem here:

dpkg-query: parse error, in file `/var/lib/dpkg/available' near line
197755 package `libstdc++2.10':
 newline in field name `ü?'

Anyway, dpkg would fail every time it tried to parse through
the file and so, from the symptoms, I thought dpkg itself
was broken.  Instead it was just the file.

I corrected by manually removing the file and then
using dselect to rebuild.



On Tue, 2002-08-06 at 21:55, Heitzso wrote:
> I run debian unstable i386 and yesterday ran apt-get
> update/upgrade.  After which dpkg breaks and cannot
> install anything that is downloaded.
> ==> I have not been able to run dpkg to install an
> older, working version of dpkg, of course, because
> dpkg is broken.
> That means that, if you hit whatever bad version
> of dpkg I hit (or ?? package that's snarling dpkg)
> you are at least mildly hosed.  (i.e. cupsys is
> also currently broken and I cannot install cupsys
> from testing to get my printer working, or switch
> over to another printing system, because those
> packages have to be installed with dpkg, etc.)
> Any clues re how to untangle this would be most
> graciously appreciated.
> Otherwise -- if you haven't upgraded w/ apt-get
> in awhile and you run unstable I suggest _NOT_
> until others more knowledgeable than I either point
> out the errors of my way or give an "ALL CLEAR"
> sign.
> Heitzso
> -- 
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: