[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#149974: debootstrap should download aptitude

On Sat, 15 Jun 2002, Anthony Towns wrote:

> tag 149974 - patch
> thanks
> On Fri, Jun 14, 2002 at 04:02:11PM +0200, Ivo Timmermans wrote:
> > The new base-config package in sid depends on aptitude, so debootstrap
> > should download it.
> Bleh. Guys, please file the bug on debootstrap *before* adding new
> dependencies to base packages and breaking it completely.
> Joey, are you sure it wouldn't have been better to make base-config use
> aptitude if present, and file a wishlist bug on debootstrap to ensure
> its presence on normal installs?
> -dpkg guys, cc'ed so we don't get the same thing happening with the
> presumably forthcoming dselect package. -boot guys, cc'ed in the probably
> vain hope that anyone else likely to do this in future will notice too.

We've done it correctly.  dpkg 1.10 predepends on dselect.  dselect 1.10
replaces dpkg (<< 1.10).  This will ensure upgrades, and no loss of

I assume this is what you were talking about dselect.

To UNSUBSCRIBE, email to debian-dpkg-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: