[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#134475: dpkg: --no-act -i package don't show problems with dependencies

Package: dpkg
Version: 1.9.17
Severity: wishlist

Some packages have very big number of dependencies. My idea is to show
problems with them in following command 'dpkg --noact -i package'.
In current version lines like 

(Reading database ... 74653 files and directories currently installed.)
Preparing to replace galeon 1.0.2-0.1 (using galeon_1.0.3-0.3_i386.deb) ...

are completely useless. In fact when i don't have previous version of package
and new has problems with dependencies but replaces old one (or more badly
new is divided into two packages, one with same name), app which depends
on that package can have problems.

-- System Information
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux pisidlo 2.2.19 #25 Wed Jan 23 20:00:08 CET 2002 i686
Locale: LANG=cs_CZ, LC_CTYPE=cs_CZ

Versions of packages dpkg depends on:
ii  libc6                  2.2.4-7           GNU C Library: Shared libraries an
ii  libncurses5            5.2.20010318-3    Shared libraries for terminal hand
ii  libstdc++2.10-glibc2.2 1:2.95.4-0.010902 The GNU stdc++ library

Reply to: