[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dpkg conffiles weirdness

I've just had a bizarre experience upgrading from test-cycle-1 to
test-cycle-2, perhaps someone can shed some light?

I used dselect with an APT backend.  One of the upgraded packages was
xterm, from version 3.3.6-6 to 3.3.6-7.  There's a conffile in the
package: /etc/X11/Xresources/xterm.  I had a modified version, which
was unceremoniously moved to xterm.dpkg-old and replaced by the new
version.  No questions were asked.  (Incidentally, the backspace key
in emacs in an xterm now behaves like ctrl-H.  Any ideas why?  Yuck!) 

I tried reinstating the old xterm conffile and reinstalling version
3.3.6-7, but now the conffile wasn't touched.  I then tried deleting
the conffile and reinstalling; no conffile was installed at all this
time.  Purging and reinstalling reinstalled the conffile, but nothing
less would do so.

Does anyone have a clue what might be up?



  Julian Gilbey, Dept of Maths, QMW, Univ. of London. J.D.Gilbey@qmw.ac.uk
        Debian GNU/Linux Developer,  see http://www.debian.org/~jdg
  Donate free food to the world's hungry: see http://www.thehungersite.com/

Reply to: