[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian packages to upgrade for the new perl(s)

[ This is an automated message sent to all maintainers having at
  least one package that depends on perl ]
Hello Ian Jackson and others,

you are maintaining the following packages that will need to be updated
(rapidly if possible) :
- dpkg-dev
If you want to know more about the perl upgrade, you can read
this message from Darren Stalder (the perl maintainer) in debian-devel :

You may also want to read the new perl policy that has been included
in the new perl-5.00X-doc packages. You can find it on the web
here : http://pandora.debian.org/~hertzog/

What do you need to change in your packages ?

If your package is a simple perl script, you will need to change
the dependency to perl by a dependency to perl5. But perl5 is a
virtual package, so you cannot have a versionned dependency on it.
You can assume that perl5 is perl (>= 5.004.05). If you really
need a versionned dependency then you'll have to depend on perl-5.004
or perl-5.005. But that does mean that you'll have to update
the dependency when perl-5.006 comes out !

If your package is a pure perl module (aka a non-binary module)
then it will have to depend on perl5. The modules have to be installed
in /usr/lib/perl5 (and NOT in a versionned directory). You really
should follow the instructions given in the perl policy because
your rules files will not need to be changed for any new perl
release (or any new release of the perl module).

If your package is a binary perl module then it must be recompiled 
with perl-5.005 and depend on perl-5.005. The modules will
be installed in a versionned directory. Once again you should
follow the instruction of the perl policy as it will allow
someone to easily recompile the perl module for another perl (by using
something like that : PERL=perl-5.006 debuild -e PERL).

If you're using debhelper, you can now use dh_perl for automatically
adding the good dependency. Simply put ${perl:Depends} in your
control file and run dh_perl in your rules files. It works well for
the modules and for the perl scripts. dh_perl is in debhelper (>= 1.2.80).

If you do not want to install perl-5.005 for recompiling your
modules or if you cannot do the required job for another reason,
then please ask on debian-perl@lists.debian.org if somebody 
else can do it for you (he will do a NMU).

If you have a question don't hesitate to ask on debian-perl or 
simply reply to this mail.

   Raphaël Hertzog <hertzog@debian.org>

PS: You may want to wait until the new perl(s) are effectively
    installed in potato (they are in Incoming and will be installed
    in a few days) before uploading your updated packages.

Reply to: