[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#31521: dpkg: dpkg dying in eterm

On Wed, 6 Jan 1999, Ian Jackson wrote:

> Fredrik Juhlin writes ("Bug#31521: dpkg: dpkg dying in eterm"):
> > I'm experiencing the exact same problem, only I'm running xterm.
> > I've so far experienced it on systems running XFree86 and 3.3.3.
> > I'm afraid I can't give a history of dpkg, tar or gzip versions, only that
> > the ones I've used lately, which are:
> > 
> > ii  dpkg       Package maintenance system for Debian Linux
> > ii  tar             1.12-6         GNU tar
> > ii  gzip            1.2.4-27       The GNU compression utility.
> > 
> > It's always been hamm-installations though.
> > 
> > Oh, and trying it in a console instead did fix it.
> Then that would be a bug in whatever invoked dpkg or some ancestor of
> it.
All the times I can remember it has been either dselect (using the
ftp-method) or just invoking dpkg from the command line.

> Can you reproduce the problem ?
The problem is consistent not in the way that all packages are suffering
from it, but in the way that a package that fails does so every time.

> In case dpkg is too difficult a program, try the rune:
>   dd if=/dev/zero | true
I first tried it on the computer I finally got upgraded to Slink, and it
gave me:
wizball:~# dd if=/dev/zero | true
1+0 records in
0+0 records out
Broken pipe

However, trying it on my computer at home, which still runs Hamm and that
has showed the same symptoms, I get:
leonov:~# dd if=/dev/zero | true
9+0 records in
8+0 records out
Broken pipe

I'm guessing that the important difference with the listings below
is the dd:/dev/full... line, which doesn't show on any of the systems.

Btw, I tried removing and reinstalling packages (that formerly wouldn't
get installed properly in an xterm) on my recently upgraded computer and
it now works just fine.

> which should say
>   jura:~> dd if=/dev/zero | true
>   1+0 records in
>   0+0 records out
>   Broken pipe
>   jura:~>
> rather than
>   jura:~> dd if=/dev/zero | true
>   dd: /dev/full: Broken pipe
>   1+0 records in
>   0+0 records out
>   jura:~>

If you think a strace-log of a failed package-installation would help,
I've got one lying around here somewhere.

Best regards,
    Fredrik Juhlin        laz@rjdk.com        http://www.rjdk.com/
    Cellular: +46 (0)709 52 40 72      Office: +46 (0)31 755 25 10
                                Quidquid latine dictum sit, altum viditur.

Reply to: