[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#489132: upgrade apt/aptitude first

Last days I have tried to understand why apt/aptitude need to be upgraded first.

Based on what I have found, I propose the following note to be inserted as section 4.5.4 of the release note:

"Several bug reports have shown aptitude and apt in etch are quiet often
unable to handle the upgrade to lenny. In lenny, apt better deals with complex
chains of packages requiring immediate configuration and aptitude is
smarter in searching solutions for satisfying the dependencies. As these two
features are heavily involved during the dist-upgrade to lenny, it is then required to upgrade those two packages before upgrading anything else:

#  aptitude install apt aptitude					"

Reply to: