[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

bugreports to systemd are getting rejected


this is getting embarrassing. Sorry for the noise but every time I try to report a bug to systemd, I am getting a failure of delivery. This only happens with systemd, I can report bugs to other packages just fine.

I'm forwarding the message. Slightly edited to remove the gmail account that I use to forward emails out from my personal machine.

This is the 3rd bug that I try to report that gets this response. I've already privately informed other people about this problem and apparently nothing was done because I still can't submit bugs.

Could you please let people submit bugs, so that they can be fixed? The alternative is releasing a buggier stable Debian.


-------- Forwarded Message --------
Subject: Delivery Status Notification (Failure)
Date: Fri, 10 Oct 2014 16:45:52 +0000
From: Mail Delivery Subsystem <mailer-daemon@googlemail.com>
To: my-supersecret-address@gmail.com

Delivery to the following recipient failed permanently:


Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain bugs.debian.org by buxtehude.debian.org. [].

The error that the other server returned was:
550 malware detected: Sanesecurity.Junk.3451.UNOFFICIAL: message rejected

----- Original message -----

DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;





X-Received: by with SMTP id jg4mr6243363wid.28.1412959544263;
        Fri, 10 Oct 2014 09:45:44 -0700 (PDT)
Return-Path: <my-supersecret-address@gmail.com>
Received: from hal9000 ([])
by mx.google.com with ESMTPSA id eg8sm3175548wib.15.2014.
        for <multiple recipients>
        (version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Fri, 10 Oct 2014 09:45:42 -0700 (PDT)
Sender: Salvo Tomaselli <my-supersecret-address@gmail.com>
Received: from [] (localhost [])
	by hal9000 (Postfix) with ESMTP id 0A14BDFA49;
	Fri, 10 Oct 2014 18:45:37 +0200 (CEST)
Content-Type: multipart/mixed; boundary="===============1018610572898679071=="
MIME-Version: 1.0
From: Salvo Tomaselli <tiposchi@tiscali.it>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: systemd: ignores user settings and shuts systemd down when power button is
Message-ID: <20141010164536.2544.59159.reportbug@localhost>
X-Mailer: reportbug 6.5.1
Date: Fri, 10 Oct 2014 18:45:36 +0200

Package: systemd
Version: 215-5+b1
Severity: important

Dear Maintainer,

despite I have a script listening to events from acpid, which I use to decide which actions to take when ACPI events occur, my system was just going off whenever I
would press the power button.

It appears that the culprit is systemd.

According to the manpage, the default values for this file /etc/systemd/logind.conf are set so that systemd will shutdown the system in case the power button is pressed.

Once upon a time, this was done by acpid, which would first check if there were sessions
open, and then decide what to do.

If you think that systemd should take over and replace acpid, it should: behave in the same way, by default, and provide a unix socket that lists the events, for backwards compatibility.

In any case, I think that the default values in that file are not sane, because for example, if I tried to configure KDE to do something when the power button is pressed, systemd would
still shutdown the system.

Best, and thanks for your work!

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***

-- Package-specific info:

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.16.4a (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages systemd depends on:
ii  acl             2.2.52-2
ii  adduser         3.113+nmu3
ii  initscripts     2.88dsf-53.4
ii  libacl1         2.2.52-2
ii  libaudit1       1:2.4-1
ii  libblkid1       2.25.1-3

----- Message truncated -----

Reply to: